問題
.NET アプリのトラフィックを生成して 5 分間待っても、データが New Relic の UI に表示されません。
解決
重要
パーミッションを変更する前に、システム管理者に確認してください。
アプリ プール ID が、次の場所にある New Relic レジストリ キーにread
アクセスできることを確認します。
HKLM\SOFTWARE\New Relic\.NET Agent\
システム上のすべてのユーザーにこのレジストリキーへのアクセスを許可するか、アプリプールのIDのみにアクセスを許可するかを選択します。
- 管理者として、Windowsのレジストリを開きます。
- コンピュータ> HKEY_LOCAL_MACHINE> ソフトウェア> New Relic を選択します。 .NET Agent を右クリックして、 Permissions を選択します。
- [グループ名またはユーザー名] リストにEveryoneユーザーが表示されない場合は、ユーザーを作成します。 [追加] を選択します。次に、 [ユーザーまたはグループの選択] から: [選択するオブジェクト名を入力してください] フィールドに
Everyone
と入力します。[ OK]を選択します。 - Group or user names リストで、 Everyone を選択します。次に、 Permissions for のテーブルで、 Allow のチェックボックスを選択して、 Read のパーミッションを設定します。
この標準フォーマットを使用するアプリプールのアイデンティティを決定します。
IIS AppPool\APP_POOL_NAME
管理者として、Windowsのレジストリを開きます。
コンピュータ> HKEY_LOCAL_MACHINE> ソフトウェア> New Relic を選択します。 .NET Agent を右クリックして、 Permissions を選択します。
[ .NET Agent のアクセス許可] ダイアログから、[追加] を選択します。次に、 [ユーザーまたはグループの選択] から: [選択するオブジェクト名を入力してください] フィールドに、アプリ プール ID ( IIS AppPool\APP_POOL_NAME
など) を入力します。[ OK]を選択します。
Group or user names リストで、新しいアプリプールの ID を選択します。次に、 Permissions for テーブルで、 Allow のチェックボックスを選択して、 Read のパーミッションを設定します。
コマンドラインから、 IISRESET を実行します。
パーミッションを更新しても問題が解決しない場合は、.NETエージェントのトラブルシューティングの手順に従って、 missing data 。
ヒント
今後のインストールでこの問題が発生しないようにするには、WSM 3.3.5.0をアンインストールしてください。レジストリに変更を加えたくない場合は、WSMと.NETをアンインストールしてから、最新版を再インストールしてください。
原因
データが表示されない一般的な理由は、New Relic .NET エージェントがそのレジストリキーにアクセスできないことです。プロファイラーのログでは、以下のようにレジストリの許可エラーが表示されることがあります。
%ALLUSERSPROFILE%\New Relic\.NET Agent\Logs\
例えば、以下のようなものがあります。
[Info] ... Logger initialized
[Error] ... Unable to find New Relic Home directory in registry or environment.
[Error] ... An exception was thrown while initializing the profiler.