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문제 신고

데이터 및 레지스트리 키 권한 문제 없음

문제

.NET 앱에 대한 트래픽을 생성하고 5분을 기다린 후에도 데이터는 여전히 New Relic UI에 표시되지 않습니다.

해결책

중요

권한을 변경하기 전에 시스템 관리자에게 확인하십시오.

  1. 앱 풀 ID에 다음 위치에 있는 New Relic 레지스트리 키에 대한 read 액세스 권한이 있는지 확인합니다.

    HKLM\SOFTWARE\New Relic\.NET Agent\
  2. 시스템의 모든 사용자에게 이 레지스트리 키에 대한 액세스 권한을 부여하거나 앱 풀 ID만 키에 액세스할 수 있도록 허용합니다.

  3. 명령줄에서 IISRESET 을 수행합니다.

  4. 권한을 업데이트해도 문제가 해결되지 않으면 .NET 에이전트의 누락된 데이터 문제 해결 절차를 따르십시오.

향후 설치 시 이 문제가 발생하지 않도록 하려면 WSM 3.3.5.0을 제거하십시오. 레지스트리를 변경하지 않으려면 WSM 및 .NET을 제거한 다음 최신 버전을 다시 설치하십시오.

원인

데이터가 표시되지 않는 일반적인 이유는 New Relic .NET 에이전트가 레지스트리 키에 액세스할 수 없기 때문입니다. 다음 위치의 프로파일러 로그에서 레지스트리 권한 오류를 볼 수 있습니다.

%ALLUSERSPROFILE%\New Relic\.NET Agent\Logs\

예를 들어 다음을 볼 수 있습니다.

[Info] ... Logger initialized
[Error] ... Unable to find New Relic Home directory in registry or environment.
[Error] ... An exception was thrown while initializing the profiler.
Copyright © 2024 New Relic Inc.

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