Security Bulletin NR18-08

Summary

A security update for the Node.js agent fixes a vulnerability in the https-proxy-agent module.

Release date: Apr 12, 2018

Vulnerability identifier: NR18-08

Priority: Low

Affected software

The following New Relic agent versions are affected:

Name Affected version Notes Remediated version
Node.js agent All 4.0.0

Vulnerability information

The New Relic Node.js agent uses https-proxy-agent as an option to send data to the New Relic collector via an HTTP or HTTPS proxy server. The Node.js agent used a version of this module which was vulnerable to Uninitialized Memory Exposure and Denial of Service. This fix updates the module to a version that is not vulnerable.

Mitigating Circumstances

Triggering this security vulnerability requires control of the agent proxy authentication configuration.

Workarounds

New Relic has not identified any workarounds for this vulnerability.

Report security vulnerabilities to New Relic

New Relic is committed to the security of our customers and their data. If you believe you have found a security vulnerability in one of our products or websites, we welcome and greatly appreciate you reporting it to New Relic's coordinated disclosure program. For more information, see Reporting security vulnerabilities.

For more help

Additional documentation resources include:.

If you need more help, check out these support and learning resources: