Update the Ruby agent

To take full advantage of New Relic's latest features, enhancements, and important security patches, we recommend you update your Ruby agent to the latest version. For additional information about specific agent updates, refer to the Ruby agent release notes.

Verify your Ruby agent versions

To determine which Ruby agent versions your apps currently use:

  1. From the account dropdown in the New Relic UI, select Account settings > Connected agents.
  2. Optional: Sort by Oldest agent version.

Update the agent

To update the Ruby agent:

  • Using Bundler: Run this command:

    bundle update newrelic_rpm
  • Not using Bundler: Run this command:

    gem update newrelic_rpm

Instrument JRuby

For correct instrumentation:

Otherwise, if your application has no transactions and you are using JRuby, you will not be able to see your CPU metrics. This was due to a bug in JRuby, where Process.times returned wall clock time instead of elapsed CPU time. That bug was fixed as of New Relic’s Ruby agent 3.6.8.164 and JRuby 1.7.0.

Ruby agent versions not supported

End of life notification: As of January 26, 2015, New Relic will no longer accept data from Ruby agent versions earlier than 3.9.6.

These agent versions use an out-of-date protocol when communicating with New Relic's data collection services. In addition, many of these versions contain a potential security issue where they may incorrectly send sensitive data to the New Relic collector.

Update unsupported agent versions

If you are updating from an older agent version, including major version jumps, review the following list for changes in functionality.

Migration Comments
From version 5 to 6

Release notes: Ruby agent 6.0.0.351

With the addition of the Tracer API for flexible custom instrumentation, several APIs were deprecated. If used, they need to be updated. For more information, see Ruby custom instrumentation.

From version 4 to 5

Release notes: Ruby agent 5.0.0.342

SSL connections to New Relic are now mandatory.

From version 3 to 4

Release notes: Ruby agent 4.0.0.332

The agent no longer supports Ruby versions prior to 2.0, JRuby 1.7 and earlier, and all versions of Rubinius.

Deprecated API calls

For a list of deprecated API calls and their replacements, see Update deprecated API calls.

For more help

Recommendations for learning more: