Resolve .NET and SCOM conflicts

Problem

The agent reports successfully, then stops after a maintenance event such as an IIS reset or system reboot. Running the Status Monitor repair utility fixes the issue temporarily, but the issue returns after the next maintenance event. If these symptoms occur and you are using Microsoft's System Center Operations Manager (SCOM), you are experiencing a SCOM profiler conflict.

Solution

To resolve SCOM profiler conflicts:

  1. Disable SCOM's Application Performance Monitoring feature.
  2. Use the .NET Status Monitor to repair your installation.
  3. If repairing your installation does not resolve the conflict, restore the registry settings via PowerShell. You will need to run these commands each time you restart your server. You can also create a startup script to restore these settings. Run these commands:
    $HKLM = 2147483650 #HKEY_LOCAL_MACHINE
    $reg = [wmiclass]"\\.\root\default:StdRegprov"
    $key = "SYSTEM\CurrentControlSet\Services\W3SVC"
    $name = "Environment"
    $value = "COR_ENABLE_PROFILING=1","COR_PROFILER={71DA0A04-7777-4EC6-9643-7D28B46A8A41}","NEWRELIC_INSTALL_PATH=C:\Program Files\New Relic\.NET Agent\"
    $reg.SetMultiStringValue($HKLM, $key, $name, $value)
    $key = "SYSTEM\CurrentControlSet\Services\WAS"
    $name = "Environment"
    $value = "COR_ENABLE_PROFILING=1","COR_PROFILER={71DA0A04-7777-4EC6-9643-7D28B46A8A41}","NEWRELIC_INSTALL_PATH=C:\Program Files\New Relic\.NET Agent\"
    $reg.SetMultiStringValue($HKLM, $key, $name, $value)
    iisreset
  4. Recycle your app pool or perform an IIS restart. To restart IIS: From a command prompt, run IISRESET.

You will need to repair your installation each time you restart your server.

Cause

Microsoft's System Center Operations Manager (SCOM) includes an Application Performance Monitoring feature which conflicts with New Relic's .NET agent. Both employ the .NET Profiler interface, and only one profiler can be used at a time.

If you have both SCOM and your .NET agent installed on the same Windows server, disabling or turning off Application Performance Monitoring in SCOM will remove some Windows registry settings that are necessary for the New Relic .NET agent to work. The .NET agent will not be able to monitor web applications on that server.

For more help

Join the discussion about .NET monitoring in the New Relic Online Technical Community! The Technical Community is a public platform to discuss and troubleshoot your New Relic toolset.

If you need additional help, get support at support.newrelic.com.