Problem
The .NET Common Language Runtime (CLR) only allows one profiler to access the profiling API of a process at any given time. If another profiler is installed on the system, the New Relic profiler will not instrument any applications.
Solution
To avoid a profiler conflict, fully remove the other profiler from the environment, then ensure the IIS registry keys or system environment variables have been restored.
Exception: For conflicts with Microsoft's System Center Operations Manager (SCOM), follow the troubleshooting procedures specifically for SCOM.
Cause
Here are some commonly reported profiler conflicts. This is not an exhaustive list of .NET profilers, as any program that uses the .NET profiling API may cause conflicts with the New Relic .NET profiler.
Profiler name | Profiler identifier |
---|---|
APM Insight | 989D151B-3F31-482E-926F-2E95D274BD36 |
App Dynamics | AppDynamics.AgentProfiler |
Dynatrace | DA7CFC47-3E35-4c-4e-B495-534F93B28683 B7038F67-52FC-4DA2-AB02-969B3C1EDA03 |
Diagnostic Policy Service | 555908D1-A6D7-4695-8E1E-26931D2012F4 |
IntelliTrace | 2AA1AA98-2CAA-4FCF-86CE-EFA007737E83 |
Microsoft App Insights | 324F817A-7420-4E6D-B3C1-143FBED6D855 COR_PROFILER_PATH
|
AD5651A8-B5C8-46ca-A11B-E82AEC2B8E78 | |
JetBrains dotCover | 9AA5D52F-37E2-487D-AAEC-727478B8BDB5 |