• /
  • Log in

Install Android apps with support for legacy Android versions

If you need to monitor old versions of Android, you can use legacy versions of the Android agent:

  • To support Android versions lower than 4.0, use version 5.19.1 or earlier of the Android SDK. This is referred to as the legacy version.
  • To support Android 2.2 specifically, use version 4.244.0 or earlier of the Android SDK.

Recommendation: If you don't need to monitor these legacy versions of Android, install or upgrade to the latest version of the agent instead. Using the latest version will give you richer data about app performance, crashes, and interactions.

Install with support for older Android version

If you have previously installed a version of the Android SDK, follow the steps before upgrading to the latest version. Then follow standard installation and configuration procedures for the Android agent.

For more help

If you need more help, check out these support and learning resources:

Create issueEdit page
Copyright © 2021 New Relic Inc.