• Log inStart now

Apollo Server plugin and Node.js

The New Relic Apollo Server plugin instruments your Apollo Server applications to give visibility into your GraphQL payloads. This helps you uncover and diagnose the cause of your slow GraphQL queries. The supported Apollo Server version is 2.14 or later.

Our plugin records overall timings for queries and uses distributed tracing to uncover the route problem. Use this instrumentation to see if the problem arises from resolving a piece of requested data or if it stems from work done on other services or databases.

Compatibility

The New Relic plugin works with the following Apollo Server modules:

  • @apollo/server
  • apollo-server (>= 2.14)
  • apollo-server-express
  • apollo-server-hapi
  • apollo-server-koa
  • apollo-server-fastify
  • apollo-server-lambda

Because fastify is not fully instrumented in the Node.js agent, transactions are prefixed with WebTransaction\Nodejs.

Other plugins may work, depending on their underlying implementation, but they have not been verified.

GitHub documentation

For detailed information about installation, configuration, transaction details, metrics, segments, errors, testing, troubleshooting, and more, see New Relic's Apollo Server plugin documentation on GitHub.

Copyright © 2023 New Relic Inc.

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.