500 error when starting the API Explorer

Problem

A 500 error appears when starting the API Explorer.

Solution

To correct this, make sure you have a default account:

  1. Go to rpm.newrelic.com > (account dropdown) > User preferences.
  2. From the Default account dropdown, select your choice, then save.

Cause

This occurs when you do not have a current or valid default New Relic account associated with your login. This keeps the Explorer from displaying the API keys available to you.

For more help

Recommendations for learning more: