Ruby agent requirements and supported frameworks

This document lists compatible operating systems, security requirements, and supported frameworks for the New Relic APM Ruby agent.

Operating systems

The Ruby agent is supported on UNIX-like operating systems such as Linux, Solaris, and Mac OS X.

Security requirements

As a standard security measure for data collection, your app server must support SHA-2 (256-bit). SHA-1 is not supported.

Ruby versions

Name Supported Deprecated Experimental
JRuby ~>9.0, ~>9.1 ~>1.7.0 -
Last supported agent for ~>1.7.0 was 3.18.1.330.
MRI 2.0.0, ~>2.1.0, ~>2.2.0, ~>2.3.0, ~>2.4.0 1.8.6, 1.8.7, 1.9.2, 1.9.3 -
Last supported agent for 1.8.7, 1.9.2, and 1.9.3 was 3.18.1.330.
Last supported agent on 1.8.6 was 3.6.8.168.

Web servers

Name Supported Deprecated Experimental
passenger ~>2.2, ~>3.0, ~>4.0 - -
puma ~>2.0 ~>1.0 -
rainbows! - - 4.5.0
thin ~>1.0 - -
unicorn ~>4.0 ~>1.0, ~>2.0, ~>3.0 -
webrick - - -
Supported for all agent-supported versions of Ruby

Web frameworks

Name Supported Deprecated Experimental
grape >= 0.2.0 - -
padrino ~>0.10 - -
rack >= 1.1.0 ~>1.0.0 -
rails ~3.0.0, ~>3.1.0, ~>3.2.0, ~>4.0.0, ~>4.1.0, ~>4.2.0, ~>5.0.0, ~>5.1.0 ~>2.0.0, ~>2.1.0, ~>2.2.0, ~>2.3.0 -
Last supported agent for ~>2.1.0, ~>2.2.0, and ~>2.3.0 was 3.18.1.330.
Last supported agent for 2.0.x was 3.6.8.168.
sinatra ~>1.2.0, ~>1.3.0, ~>1.4.0, ~>2.0.0 - -

Databases

Name Supported Deprecated Experimental
activerecord ~>3.0.0, ~>3.1.0, ~>3.2.0, ~>4.0.0, ~>4.1.0, ~>4.2.0, ~>5.0.0, ~>5.1.0 ~>2.0.0, ~>2.1.0, ~>2.2.0, ~>2.3.0 -
Last supported agent for ~>2.1.0, ~>2.2.0, and ~>2.3.0 was 3.18.1.330.
Last supported agent for 2.0.x was 3.6.8.168.
datamapper ~>1.0 - -
mongo ~>1.8, ~>2.1 - -
redis ~>3.0 - -
sequel ~>3.37, ~>4.0 - -

Background jobs

Name Supported Deprecated Experimental
delayed_job ~>2.0, ~>3.0, ~>4.0 - -
rake ~>10.0 - -
resque ~>1.23.0 ~>1.22.0 >= 2.0
sidekiq ~>2.8, ~>3.4.2, ~>4.0 - -

HTTP clients

Name Supported Deprecated Experimental
Net::HTTP - - -
Supported for all agent-supported versions of Ruby.
curb >= 0.8.1 - -
excon >= 0.10.1 - -
httpclient >= 2.2.0 - -
httprb >= 0.9.9 - -
typhoeus >= 0.5.3 - -

Other

Name Supported Deprecated Experimental
activemerchant >= 1.25.0 - -
acts_as_solr - - -
authlogic - - -
dalli - - -
memcache-client - - -
sunspot - - -

For more help

Additional documentation resources include:

  • New Relic for Ruby (compatibility and requirements, general information about installation, configuration, troubleshooting, and known issues)
  • Ruby agent installation (using the New Relic Ruby gem and configuration file)

Join the discussion about Ruby in the New Relic Online Technical Community! The Technical Community is a public platform to discuss and troubleshoot your New Relic toolset.

If you need additional help, get support at support.newrelic.com.