No event log: CoCreate errors (.NET)

Problem

If your .NET application does not report data after a few minutes, and there is no New Relic event log, you may be running another profiler that conflicts with New Relic.

To verify whether New Relic is conflicting with another profiler:

  1. Check your application event log for errors like:

    NET Runtime version 2.0.50727.4234 - Failed to CoCreate profiler. Profiler CLSID: '{TRQGTQJM-KMJB-FQGP-VNGG-KUQTZWCKQ6QQ}'.
    NET Runtime version 4.0.30319.296 - Loading profiler failed during CoCreateInstance. Profiler CLSID: '{FF68FEB9-E58A-4B75-A2B8-90CE7D915A26}'.
  2. Compare the CLSID in the error to New Relic's CLSIDs:

    71DA0A04-7777-4EC6-9643-7D28B46A8A41
    FF68FEB9-E58A-4B75-A2B8-90CE7D915A26
  3. If the CLSID does not match, you may have another .NET profiler running. See Solution. If the CLSID does match, see CoCreateInstance permissions errors.

Solution

Due to the architecture of .NET, you can run only one profiler at a time. To use New Relic for .NET, uninstall the other profiler.

Cause

These errors indicate there is another .NET profiler running. The New Relic .NET agent must be registered as a profiler with the Common Language Runtime (CLR) as a profiler in order to function. The CLR calls out to the .NET agent when code is loaded, and the agent instruments the code if it's an interesting method call.

For more help

Join the discussion about .NET monitoring in the New Relic Online Technical Community! The Technical Community is a public platform to discuss and troubleshoot your New Relic toolset.

If you need additional help, get support at support.newrelic.com.