問題
アプリケーションのトラフィックが生成されてから5分間待機した後に、New Relic UIに.NETエージェントのデータが表示されません。
解決
データの欠落は、いくつかの理由によって発生します。
Common causes
データが欠落している場合:基本的なトラブルシューティングの解決策を参照してください。
Other situations:
基本的な解決策で問題が解決しない場合は、データ不足がシステムに固有の原因である可能性があります。 詳細については、高度なトラブルシューティング ソリューションを参照してください。
Microsoft Azure users:
Azure トラブルシューティング ソリューションを参照してください。
No browser data appears:
基本的な解決策
データの欠落の最も一般的な理由をトラブルシューティングするには、必要に応じて以下の解決策を試してください。
Basic solutions | Comments |
---|---|
エージェントとの互換性に関しては、アプリケーションとフレームワークを確認してください | または |
インストールに関するよくある問題について | .NET CoreおよびLinuxのトラブルシューティングまたはWindowsのトラブルシューティングを参照してください。 |
短時間の.NETプロセス向けに設定 | 短時間(60秒未満)のプロセスの場合、データがレポートされない可能性があります。詳しくは、短時間のプロセスをモニターするをご覧ください。 |
.NET Core: Kestrel の要件を確認してください。 | New RelicがサポートしているKestrelのアプリケーション/ウェブサーバーを使用していることを確認します。.NETエージェントの.NET Frameworkサポートが有効化されていることを確認する必要があります。 |
.NET Core: 環境変数を確認してください。 | 必要なすべての環境変数が設定されていることを確認してからエージェントを再起動します。 |
.NET Framework: IISを再起動する。 | アプリケーションがトラフィックを受け取っていない場合、データはNew Relicにレポートされません。IISを再起動するには:
|
New Relic Diagnosticsを実行します。 | 問題を自動的に識別するには、New Relic Diagnosticsを使用します。 |
プロファイラーの競合を確認します。 | Microsoft System Center Operations Manager(SCOM)を使用している場合は、.NETとSCOMの競合を解決するトラブルシューティング手順に従います。 |
ログファイルを確認します。 | ログファイルがある場合は、開いてエラーを確認します。 |
高度な解決策
より複雑なデータが表示されない問題を解決する場合は、必要に応じて以下の解決策を試めしてください。
Advanced solutions | Comments |
---|---|
.NET Framework: レジストリの権限を確認してください。 | レジストリキーのアクセス権限のエラーを確認します。 |
.NET Framework: Windows イベント ビューアーを実行します。 | 該当する場合:
|
デバッグログを取得します。 | ログにエラーが表示されない場合は、一時的にロギングレベルを上げてログを |
プロキシ設定を確認します。 | プロキシ設定が正しく、その設定にホスト属性が含まれていることを確認します。 |
.NET 8: ランタイム診断が有効になっていることを確認してください | .NET 8以降では、環境変数 |
その他のヘルプを参照します。 | それでもデータが表示されない場合は、support.newrelic.comでサポートを受けます。 |