AngularJS errors do not appear

Problem

You're using AngularJS and want to report JavaScript errors to New Relic, but you don't see your application's errors in the JavaScript errors page.

Cause

AngularJS applications often include a global error handler that catches all errors, and by default, New Relic Browser only reports uncaught errors.

Solution

Use the noticeError API call to report the errors to New Relic. This allows you to handle them as part of your regular error processing, but also see them within the New Relic UI.

For more help

Discuss Browser monitoring in the New Relic Online Technical Community! Troubleshoot and ask questions, or discuss JavaScript error reporting or AJAX timing in detail.

If you need additional help, get support at support.newrelic.com.