• English日本語한국어
  • Log inStart now

Ruby agent EOL policy

The following are the specific policies and dates for support of our Ruby agent. See our documentation about general EOL policies for information about New Relic's overall end-of-life policy.

New Relic Ruby agent releases and support dates

Any versions not listed in the following table are no longer supported. Please update your Ruby agent version to the latest release.

Ruby agent release

Start date

End date

v9.7.1Jan 25, 2024Jan 25, 2025
v9.7.0Jan 10, 2024Jan 10, 2025
v9.6.0Oct 30, 2023Oct 30, 2024
v9.5.0Sep 12, 2023Sep 12, 2024
v9.4.2Aug 18, 2023Aug 18, 2024
v9.4.1Aug 16, 2023Aug 16, 2024
v9.4.0Aug 15, 2023Aug 15, 2024
v9.3.1Jul 11, 2023Jul 11, 2024
v9.3.0Jun 26, 2023Jun 26, 2024
v9.2.1May 1, 2023May 1, 2024
v9.2.2May 1, 2023May 1, 2024
v9.2.0Apr 17, 2023Apr 17, 2024
v9.1.0Mar 29, 2023Mar 29, 2024
v8.9.0Jul 11, 2022Jul 11, 2024
v8.8.0Jun 2, 2022Jun 2, 2024
v8.7.0May 3, 2022May 3, 2024
v8.6.0Apr 4, 2022Apr 4, 2024
v8.5.0Feb 24, 2022Feb 24, 2024

Ruby runtimes

The latest version of the New Relic Ruby agent may support a Ruby version outside the Ruby Maintenance Branches policy set by the Ruby Core community. Support for older Rubies is often dropped during a major agent version release.

New Relic Ruby agent version

Min Ruby version

9.x

2.4.0

8.x

2.2.0

7.x

2.0.0

6.x

2.0.0

5.x

2.0.0

4.x

2.0.0

3.x

1.8.7

Copyright © 2024 New Relic Inc.

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.