Problem
If your log data shows SEVERE:
or ERROR:
with NullPointerException
issues, there may be issues that are interfering with reporting.
Solution
Before you begin these troubleshooting tips, make sure you have the most recent version of New Relic's Java agent.
- Use case-sensitive searches of your Java agent log file for lines with
SEVERE:
andERROR: NullPointerException
. - If you find any lines with these messages, gather troubleshooting information to get support at New Relic.
Cause
New Relic's Java agent between versions 3.0.0 and 3.2.3 would incorrectly log the error messages. For example:
ERROR: javax/servlet/ServletOutputStream is marked as a weaved class, but no methods are matched to be weaved.
This was entirely erroneous and is not a cause for concern. However, do not use these versions. Instead, update to the most recent version of New Relic's Java agent.