Problema
Depois de gerar tráfego para seu aplicativo .NET e esperar cinco minutos, os dados ainda não aparecem na interface do New Relic.
Solução
Importante
Verifique com o administrador do sistema antes de alterar as permissões.
Certifique-se de que a identidade do pool de aplicativos tenha
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acesso à chave de registro do New Relic localizada em:HKLM\SOFTWARE\New Relic\.NET Agent\Conceda a todos os usuários no sistema acesso a essa chave de registro ou permita que apenas a identidade do pool de aplicativos acesse a chave.
Na linha de comando, execute um IISRESET.
Se a atualização das permissões não resolver o problema, siga os procedimentos de resolução de problemas do agente .NET para dados ausentes.
Dica
Para evitar que esse problema aconteça em instalações futuras, desinstale o WSM 3.3.5.0. Se você não quiser fazer alterações em seu registro, desinstale o WSM e o .NET e reinstale as versões mais recentes.
Causa
Um motivo comum pelo qual os dados não aparecem é porque o agente .NET da New Relic não consegue acessar suas chaves de registro. Você pode ver erros de permissão de registro no log do profiler em:
%ALLUSERSPROFILE%\New Relic\.NET Agent\Logs\
Por exemplo, você pode ver:
[Info] ... Logger initialized[Error] ... Unable to find New Relic Home directory in registry or environment.[Error] ... An exception was thrown while initializing the profiler.