• EnglishEspañol日本語한국어Português
  • 로그인지금 시작하기

사용자의 편의를 위해 제공되는 기계 번역입니다.

In the event of any inconsistency between the English version and the translated version, the English versionwill take priority. Please visit this page for more information.

문제 신고

데이터 보고 중지

문제

New Relic PHP 에이전트는 이전에 데이터를 보고했지만 보고를 중지했습니다. 게다가:

  • 에이전트 데몬 로그 파일 /var/log/newrelic/newrelic-daemon.log 을(를) 확인하면 Lack of activity within 10ms 메시지가 표시됩니다.

  • 애플리케이션의 상태는 회색입니다.

  • 응용 프로그램 삭제 옵션은 다음을 선택하면 응용 프로그램의 설정 메뉴에 나타납니다.

    상.

해결책

다음 방법 중 하나를 사용하여 애플리케이션이 유휴 상태가 되지 않도록 합니다.

  • newrelic.daemon.app_timeout 에 대한 시간 초과 값을 트랜잭션 간격의 최소 2배로 설정하십시오. 예를 들어, 시간별 백그라운드 작업의 경우 시간 제한을 2시간으로 설정합니다.
  • 권장 사항: 프로세스가 길거나 자주 발생하지 않는 경우 phpinfo() 과 같은 간단한 트랜잭션으로 5분마다 cron 작업을 실행하십시오. 이렇게 하면 응용 프로그램이 유휴 상태가 되지 않도록 하는 데 도움이 됩니다.

중요

cron 작업을 무시하도록 newrelic_ignore_transaction 을 설정하지 마십시오. 작업이 실행 및 보고되지 않으면 PHP 에이전트가 유휴 상태가 됩니다.

원인

응용 프로그램의 트랜잭션이 10분보다 오래 걸리거나 10분에 한 번 미만으로 발생하는 경우 응용 프로그램은 유휴 상태로 들어가고 유지됩니다.

PHP 에이전트가 유휴 상태에 있을 때 다시 보고를 시작하려면 두 가지 트랜잭션이 발생해야 합니다.

  • 첫 번째 트랜잭션은 데몬을 깨우고 New Relic에 대한 연결을 다시 설정합니다.
  • 두 번째 트랜잭션은 New Relic에 데이터를 보고합니다.
Copyright © 2024 New Relic Inc.

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.