• English日本語한국어
  • ログイン今すぐ開始

この機械翻訳は参考用に提供されます。

英語版と翻訳版に矛盾がある場合は、英語版が優先されます。詳細については、 を参照してください。

問題を作成する

データが報告されなくなる

問題

New Relic PHP エージェントは、以前はデータを報告していましたが、その後報告しなくなりました。さらに、このような

  • エージェントデーモンのログファイル /var/log/newrelic/newrelic-daemon.log を確認したところ、 Lack of activity within 10ms というメッセージが表示されていました。

  • アプリケーションの健康状態はグレーです。

  • アプリケーションを削除するオプションは、アプリケーションの 設定 メニューで、

    アイコンを選択すると表示されます。

解決策

アプリケーションがアイドル状態にならないようにするには、これらの方法のいずれかを使用します。

  • newrelic.daemon.app_timeout のタイムアウト値を、トランザクションの間隔の2倍以上に設定してください。たとえば、1時間ごとのバックグラウンド・ジョブの場合、タイムアウトを2時間に設定します。
  • 推奨: 処理時間が長い、または処理頻度が低い場合は、 phpinfo() のような単純なトランザクションで、5分ごとにcronジョブを実行してください。これにより、アプリケーションがアイドル状態にならないようにすることができます。

重要

newrelic_ignore_transaction を設定して cron ジョブを無視しないでください。ジョブが実行されずに報告されない場合、PHP エージェントはアイドル状態になります。

原因

アプリケーションのトランザクションに10分以上かかる場合や、10分に1回以下の頻度で発生する場合は、アプリケーションはアイドル状態になります。

PHPエージェントがアイドル状態になったとき、 2つの トランザクションが発生しないと、再びレポートを開始しません。

  • 最初のトランザクションでは、デーモンを起動し、New Relicへの接続を再確立します。
  • 2つ目のトランザクションは、New Relicにデータを報告します。
Copyright © 2023 New Relic Inc.

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.