• ログイン今すぐ開始

本書は、お客様のご参考のために原文の英語版を機械翻訳したものです。

英語版と齟齬がある場合、英語版の定めが優先するものとします。より詳しい情報については、本リンクをご参照ください。

問題を作成する

セキュリティブルテンNR19-02

概要

エージェントが高セキュリティモードまたは設定可能なセキュリティポリシーで構成されている場合でも、リクエストパラメーターがセグメント属性として追加されるという問題がありました。これにより、予期しないデータが収集されることがあります。

発売日: 2019年4月1日

脆弱性の識別子: NR19-02

Priority: Medium

対象となるソフトウェア

以下のNew Relicエージェントのバージョンが影響を受けます。

名前

影響を受けるバージョン

メモ

リメディエーション版

Node.jsエージェント

3.0.0-5.6.2

5.6.3

脆弱性情報

設計上、リクエストパラメーターはセグメントアトリビュートとして追加されます。リクエストパラメーターは、エージェントが高セキュリティモードまたは attributes_include Configurable Security Policy で構成されている場合には無視されるべきです。

緩和要因

High Security Modeまたは attributes_include Configurable Security Policyで構成されたエージェントにのみ影響します。

回避策

セキュリティの脆弱性をNew Relicに報告

ニューレリックは、お客様とそのデータのセキュリティを重視しています。私たちの製品やウェブサイトにセキュリティ上の脆弱性を発見したと思われる場合は、New Relic の協調的な情報開示プログラムに報告していただくことを歓迎し、大変感謝しています。詳細については、 Reporting security vulnerabilities をご覧ください。

Copyright © 2022 New Relic株式会社。

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.