• EnglishEspañol日本語한국어Português
  • ログイン今すぐ開始

この機械翻訳は、参考として提供されています。

In the event of any inconsistency between the English version and the translated version, the English versionwill take priority. Please visit this page for more information.

問題を作成する

AWS統合におけるメトリックデータの遅延

問題

AWS統合がAPIリクエストを行ってから、インフラストラクチャがメトリックデータを返すまでの間に遅延が発生します。

解決

AWSとの連携によっては、APIリクエストからメトリックデータが返されるまでのタイミングに明示的な遅延や暗黙的な遅延がインフラエージェントに発生する場合があります。この原因の詳細については、 原因 を参照してください。

通常、遅延は合計されません。明示的な遅延を使用すると、New Relic はメトリックデータが遅延時点のものであることを期待します。たとえば、New Relic が 5 分の明示的な遅延を使用している場合、9 時の時点で最も新鮮なデータポイントは 8:55 のものになるはずです。

ただし、遅延時間はお客様やアカウントによって異なる場合があります。メートル法のデータに異常な遅延が発生した場合。

  1. インフラストラクチャ統合に、メトリックデータのAPIリクエストで明示的な遅延または暗黙的な遅延があるかどうかを確認します。
  2. CloudWatchユーザー。CloudWatchコンソールに表示されるメトリックデータのスクリーンショットを撮り、 support.newrelic.com にサポートを依頼する際に添付してください。

CloudWatchコンソールのスクリーンショットを使用して、New Relicサポートは、遅延がインフラストラクチャで発生しているか、AWSで直接発生しているかのトラブルシューティングを行います。

原因

AWSとの連携によっては、インフラエージェントがAPIリクエストからメトリックデータを返すまでのタイミングに明示的な遅延や暗黙的な遅延が発生することがあります。

メトリックデータの遅延

コメントコメント

明示的なディレイ

(具体的にはセット)

明示的な遅延とは、より信頼性の高いデータを得るためにNew Relicがコードに設定するものです。AWSへのAPIリクエストではある値が返ってきても、1分後に同じ指標をリクエストすると違う値が返ってくるケースがあります。このような事態が発生する可能性を減らすために、New Relic では明示的な遅延を設定しています。例えば、以下のようなものです。

  • New Relic が 5 分の明示的な遅延を使用している場合、9 時の API コールは 8:50 から 8:55 までのメトリクスを要求します。

  • New Relic が 5 分間の明示的な遅延を使用していない場合、9 時の API 呼び出しは 8:55 から 9:00 までのメトリクスを要求します。

    次の Amazon 統合により、明示的な遅延が発生する可能性があります。

  • ALB: 5分

  • ELB: 5分

  • CloudFront :3分

  • RDS: 5分

  • SNS: 10分

インプリシットディレイ

(期待されているが、特に設定されていない)。

暗黙の遅延とは、New Relic が統合の際に経験したパターンです。これらは常に存在するわけではなく、また正確でもありません。

一般に、暗黙的な遅延は、次の Amazon 統合を含む AWS CloudWatch メトリクスのリクエストから発生する傾向があります。

Copyright © 2024 New Relic株式会社。

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.