• English日本語한국어
  • ログイン今すぐ開始

この機械翻訳は参考用に提供されます。

英語版と翻訳版に矛盾がある場合は、英語版が優先されます。詳細については、こちらのページをご覧ください。

問題を作成する

パーミッションの要件を決定する(PHP)

問題

New Relic PHP エージェントをインストールして使用するために、どのようなシステムパーミッションが必要かを判断する必要があります。

解決

ほとんどのユースケースにおいて、New Relic for PHP をインストールするには root 権限が必要です。これは、インストールの過程で、root ユーザーのみが利用できる権限が必要となるためです。これらの権限には次のようなものがあります。

  • PHP extensionsディレクトリへのリード/ライトアクセス
  • PHPの設定データへの読み書き可能なアクセスは、PHP設定ディレクトリ(推奨)または php.ini のいずれかになります。
  • WebサーバーやPHPプロセスプールを再起動する機能。

エージェントの実行には、root 権限は必要ありません。エージェントは、以下のファイルへの読み書き可能なアクセス権を必要とします(これらのファイルの場所は、 PHP エージェント設定 でカスタマイズできます)。

Copyright © 2024 New Relic Inc.

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.