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Criar um problema

Falhas de firewall ou conectividade de tráfego

Problema

Os dadoslog do seu aplicativo Java mostram falhas na conexão com o New Relic. Você deseja verificar se as mensagens INFO são causadas por conectividade de tráfego ou regras de firewall, ou se são causadas por problemas mais sérios.

Solução

Falhas ocasionais na conexão ao coletor New Relic não devem ser motivo de preocupação. Essas falhas não devem afetar a métrica de desempenho disponível na interface de usuário do New Relic do seu aplicativo.

O agente Java da New Relic tenta se conectar uma vez por minuto. Para solucionar o problema:

  1. Procure em seu arquivo de log por INFO mensagens sobre falhas de conexão.
  2. Verifique com que frequência as mensagens aparecem.

Por exemplo, procure mensagens como:

Jul 31, 2017 21:37:14 +0000 NewRelic 10
INFO: Failed to connect to collector.newrelic.com.:443 for My Application:java.net.
ConnectException: Connection refused:connect

ou

Jul 31, 2017 21:37:14 +0000 NewRelic 40
INFO: The data collector is temporarily unavailable.
This can happen periodically. In the event that availability of our servers
is not restored after a period of time,
then please report this to New Relic.
java.net.SocketException: Connection reset

Dependendo da frequência com que a mensagem aparece, faça o seguinte para solucionar o problema:

Frequency of INFO message

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Alguns minutos

O agente Java da New Relic pode armazenar em cache uma quantidade significativa de dados métricos quando não consegue se conectar. Mesmo que a interrupção dure alguns minutos, em geral, isso não resultará em perda de informações na interface . Você pode ignorar essas mensagens com segurança.

Intermitentemente durante alguns dias

Problemas de conexão intermitentes podem ocasionalmente causar muitas dessas mensagens em pouco tempo. Se isso ocorrer apenas uma vez a cada poucos dias e todos os dados do seu aplicativo aparecerem na interface do New Relic, você pode ignorar essas mensagens com segurança.

Cada minuto durante vários minutos

Se falhas ocorrerem a cada minuto por mais de alguns minutos, o agente Java não poderá receber dados do seu aplicativo e nenhum dado poderá ser relatado. Nesta situação:

  1. Verifique se o New Relic está enfrentando problemas de disponibilidade: verifique o status do New Relic em status.newrelic.com.
  2. Se a New Relic não estiver relatando nenhum problema, reúna informações sobre resolução de problemas para seu aplicativo.

Causa

Apesar do texto do log, esse erro geralmente é causado por uma falha de conectividade ou tráfego protegido por firewall, em vez de o coletor New Relic estar realmente indisponível. Para obter mais informações, consulte as listas de intervalos de IP usados por todos os serviços da New Relic.

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