withApplicationVersion

NewRelic.withApplicationVersion(string $appVersion)
Set an application version to be associated with an interaction.

Requirements

Agent version 4.244.0 or higher.

Description

By default, the New Relic Android agent gets the app version from the AndroidManifest.xml or build.gradle. This method lets you override that value and set an app version by passing the app version. The app version is displayed as a dropdown in the New Relic UI, and can be used to sort interactions.

For general info on using this API, see the Android SDK API usage guide.

Parameters

Parameter Description

$appVersion

string

Required. String indicating the application version.

Example(s)

Set app version

Example of setting an app version:

NewRelic.withApplicationVersion('1.23.4')

For more help

Recommendations for learning more: