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Incorrect host name reported

Problem

The agent is working, but the infrastructure UI shows the wrong hostname or duplicated hosts appear.

Solution

Review the hostname related settings in the agent configuration. To set the correct hostname, try the following steps:

  1. Edit the newrelic-infra.yml configuration file and add the override_hostname option, whose value is your expected hostname. For example:

    override_hostname: correct-host.domain.com
  2. Use your init system to restart the agent service:

Cause

In Linux and macOS, the New Relic infrastructure agent tries to resolve its fully qualified domain name against a domain name server, which may not be properly configured or not controlled by the same user as the New Relic infrastructure agent. In Windows, it resolves the domain name using internal tools.

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