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Atrasos de dados métricos na integração AWS

Problema

Você percebe atrasos entre o momento em que sua integração AWS faz uma solicitação API e a infraestrutura retorna os dados métricos.

Solução

Dependendo da integração da AWS, o agente de infraestrutura pode enfrentar atrasos explícitos ou implícitos no tempo entre a solicitação da API e os dados de métrica retornados. Para obter mais informações sobre esta causa, consulte Causa.

Normalmente, os atrasos não se somam. Com um atraso explícito, a New Relic espera que os dados da métrica estejam no ponto de atraso. Por exemplo, se o New Relic usar um atraso explícito de cinco minutos, às 9h o ponto de dados mais recente deverá ser o das 8h55.

No entanto, os atrasos podem variar de acordo com o cliente e a conta. Se você tiver atrasos incomuns nos seus dados métricos:

  1. Verifique se a sua integração de infraestrutura possui atrasos explícitos ou implícitos com solicitações API para dados métricos.
  2. Usuário do CloudWatch: Faça uma captura de tela dos dados métricos em seu console do CloudWatch e anexe-a quando solicitar suporte em support.newrelic.com.

Usando a captura de tela do console do CloudWatch, o suporte da New Relic solucionará o problema se o atraso ocorrer na infraestrutura ou diretamente na AWS.

Causa

Dependendo da integração da AWS, o agente de infraestrutura pode enfrentar atrasos explícitos ou implícitos no tempo entre a solicitação da API e os dados de métrica retornados.

Metric data delays

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Atrasos explícitos

(definido especificamente)

Atrasos explícitos são aqueles que a New Relic define no código para obter dados mais confiáveis. Em alguns casos, a solicitação da API para a AWS pode retornar um valor, mas uma solicitação da mesma métrica um minuto depois retorna um valor diferente. Para reduzir a possibilidade de isso ocorrer, a New Relic define atrasos explícitos. Por exemplo:

  • Se New Relic usar um atraso explícito de cinco minutos, uma chamada de API às 9h solicita métrica das 8h50 às 8h55.

  • Se New Relic não usar um atraso explícito de cinco minutos, uma chamada de API às 9h solicita métrica das 8h55 às 9h.

    Atrasos explícitos podem vir destas integrações da Amazon:

  • ALB: 5 minutos

  • ELB: 5 minutos

  • CloudFront: 3 minutos

  • RDS: 5 minutos

  • SNS: 10 minutos

Atrasos implícitos

(esperado, mas não definido especificamente)

Atrasos implícitos são padrões que New Relic experimentou com integração. Eles nem sempre estão presentes e não são exatos.

Em geral, atrasos implícitos tendem a vir de solicitações de informações da AWS do CloudWatch, incluindo estas integrações da Amazon:

  • DynamoDB: Aproximadamente 1 minuto
  • EBS: Aproximadamente 15 minutos
  • EC2: Aproximadamente 5 minutos
  • ElastiCache: aproximadamente 5 minutos
  • Lambda: Aproximadamente 1 minuto
  • SQS: Aproximadamente 5 minutos
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