• EnglishEspañol日本語한국어Português
  • EntrarComeçar agora

Esta tradução de máquina é fornecida para sua comodidade.

Caso haja alguma divergência entre a versão em inglês e a traduzida, a versão em inglês prevalece. Acesse esta página para mais informações.

Criar um problema

Atualizar o agente .NET

Como atualizar o agente APM .NET.

Verifique a versão do seu agente .NET

  1. Consulte as notas de versão para encontrar a versão mais recente do agente.

  2. Verifique a versão do agente .NET que você instalou atualmente usando

    Windows Programs and Features

    ou usando seu gerenciador de pacote Linux.

Antes que você comece

Existem várias maneiras de instalar o agente .NET, o que significa que existem várias maneiras de atualizá-lo. Neste documento, focamos nos procedimentos de atualização para a instalação mais simples, com o agente .NET instalado diretamente em um host Windows ou Linux.

Se você tiver outras instalações, consulte estes documentos de instalação dessas configurações para obter mais contexto:

Instalações Windows e Linux

Siga as instruções de atualização para seu agente:

Atualizar o agente .NET (Windows)

Importante

Antes de atualizar:

  • A atualização do agente requer direitos

    Administrator

    no seu grupo de administradores do Windows. Para obter mais informações, consulte a documentação de permissões.

  • Se a versão do seu agente for inferior a 7.0 ou você estiver usando o .NET framework versão 4.0 ou inferior, consulte Atualizar o agente .NET legado.

  • Se seu aplicativo estiver hospedado no IIS, certifique-se de

    stop IIS

    antes de atualizar o agente .NET.

Atualizar o agente .NET (Linux)

Importante

Para o agente .NET versões 10.0.0 ou superior, o nome do pacote é newrelic-dotnet-agent. Para o agente .NET versões 9.9.0 ou inferior, o nome do pacote é newrelic-netcore20-agent. O restante deste documento refere-se a newrelic-dotnet-agent; substitua-o pelo nome mais antigo se você tiver uma versão mais antiga do agente instalada. Ao atualizar para a versão 10.0.0 ou superior a partir de uma versão anterior, você precisará alterar as variáveis de ambiente CORECLR_NEWRELIC_HOME e CORECLR_PROFILER_PATH devido à alteração do nome do pacote.

Use um dos seguintes métodos para atualizar para a versão mais recente do agente .NET da New Relic:

Atualizar agente do .NET framework mais antigo (inferior a 7.0)

Se você estiver pensando em atualizar uma versão do agente do .NET framework inferior a 7.0, revise as notas a seguir. Para ver a versão do agente que você possui, consulte Verificar a versão do agente. Para obter uma lista completa das alterações do agente, consulte as notas de versão do .NET.

Copyright © 2024 New Relic Inc.

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.