• EnglishEspañol日本語한국어Português
  • ログイン今すぐ開始

PHP agent release notesRSS

June 13, 2023
PHP agent v10.11.0.3

New Relic PHP Agent v10.11.0.3

Security

New features

  • Drupal 9.4 now reports hooks and modules

Bug Fixes

Important end-of-life information

  • Support for PHP versions 5.5 and 5.6 IS DEPRECATED. We recommend upgrading to at least PHP 7.0

Support statement

  • New Relic recommends that you upgrade the agent regularly and at a minimum every 3 months. For more information on supported agent versions and EOL timelines, check out our PHP EOL policy.
  • The PHP agent compatibility and requirements page should be consulted for the latest information on supported PHP versions and platforms.

重要

For installations using an unsupported PHP version or platform (32 bit, FreeBSD, ZTS, etc), it's highly recommended that you disable the auto-update mechanisms for the PHP agent packages. This can be done by adding the PHP agent packages to an exclusion list for package upgrades. Or you could version pin the PHP agent package to an agent version that supports the old, unsupported feature(s). Failure to prevent upgrades may result in a newer agent release being installed and removal of support for the required, unsupported features. This would disrupt APM data collection. The PHP agent packages which are affected are:

  • newrelic-php5
  • newrelic-php5-common
  • newrelic-daemon

May 30, 2023
PHP agent v10.10.0.1

New Relic PHP Agent v10.10.0.1

Security

New features

  • ARM64 binaries are now available for PHP 8.0, 8.1, and 8.2. Please see our docs for installation instructions.

Bug Fixes

Important end-of-life information

  • Support for PHP versions 5.5 and 5.6 will end June 2023.

Support statement

  • Support for ZTS builds ended with release v9.19.0.309 and those binaries are no longer provided.

  • New Relic recommends that you upgrade the agent regularly and at a minimum every 3 months. For more information on supported agent versions and EOL timelines, check out our PHP EOL policy.

  • The PHP agent compatibility and requirements page should be consulted for the latest information on supported PHP versions and platforms.

重要

For installations using an unsupported PHP version or platform (32 bit, FreeBSD, ZTS, etc), it's highly recommended that you disable the auto-update mechanisms for the PHP agent packages. This can be done by adding the PHP agent packages to an exclusion list for package upgrades. Or you could version pin the PHP agent package to an agent version that supports the old, unsupported feature(s). Failure to prevent upgrades may result in a newer agent release being installed and removal of support for the required, unsupported features. This would disrupt APM data collection. The PHP agent packages which are affected are:

  • newrelic-php5
  • newrelic-php5-common
  • newrelic-daemon

April 5, 2023
PHP agent v10.9.0.324

New Relic PHP Agent v10.9.0.324

Security

  • Updated the Golang version used to build the Daemon from 1.9 to 1.20

New features

Bug Fixes

Important end-of-life information

  • Support for PHP versions 5.5 and 5.6 will end June 2023.

Support statement

  • New Relic recommends that you upgrade the agent regularly and at a minimum every 3 months. For more information on supported agent versions and EOL timelines, check out our PHP EOL policy.
  • The PHP agent compatibility and requirements page should be consulted for the latest information on supported PHP versions and platforms.

重要

For installations using an unsupported PHP version or platform (32 bit, FreeBSD, ZTS, etc), it's highly recommended that you disable the auto-update mechanisms for the PHP agent packages. This can be done by adding the PHP agent packages to an exclusion list for package upgrades. Or you could version pin the PHP agent package to an agent version that supports the old, unsupported feature(s). Failure to prevent upgrades may result in a newer agent release being installed and removal of support for the required, unsupported features. This would disrupt APM data collection. The PHP agent packages which are affected are:

  • newrelic-php5
  • newrelic-php5-common
  • newrelic-daemon

March 22, 2023
PHP agent v10.8.0.323

New Relic PHP Agent v10.8.0.323

New features

  • Added healthcheck log level for the daemon, allowing for precise monitoring of the number of connected applications.

Bug Fixes

  • Fixed debian package installation occasionally requiring an additional manual step #634
  • Fixed a warning from agent when passing null as the second parameter to curl_multi_exec #605. Special thanks to dejanceltra for finding and fixing this issue!

New Contributors

This release contains the first contribution to the New Relic PHP Agent from community member dejanceltra! Thanks!!

Support statement

  • New Relic recommends that you upgrade the agent regularly and at a minimum every 3 months. For more information on supported agent versions and EOL timelines, check out our PHP EOL policy.
  • The PHP agent compatibility and requirements page should be consulted for the latest information on supported PHP versions and platforms.

重要

For installations using an unsupported PHP version or platform (32 bit, FreeBSD, ZTS, etc), it's highly recommended that you disable the auto-update mechanisms for the PHP agent packages. This can be done by adding the PHP agent packages to an exclusion list for package upgrades. Or you could version pin the PHP agent package to an agent version that supports the old, unsupported feature(s). Failure to prevent upgrades may result in a newer agent release being installed and removal of support for the required, unsupported features. This would disrupt APM data collection. The PHP agent packages which are affected are:

  • newrelic-php5
  • newrelic-php5-common
  • newrelic-daemon

March 8, 2023
PHP agent v10.7.0.319

New Relic PHP Agent v10.7.0.319

Important note

If the following error occurs when installing the newrelic-php5 Debian package:

Setting up newrelic-php5 (10.7.0.319) ...
Unknown PHP version: 8.2

Please run the newrelic-install installation program which will complete the installation of the PHP agent and set up the correct symlink to the PHP extension directory.

New features

  • Added Support for PHP 8.2.

Important end-of-life information

  • Support for PHP versions 5.5 and 5.6 will end June 2023.

Support statement

  • Support for 32 bit and FreeBSD ended with release v9.19.0.309 and those binaries are no longer provided.
  • Support for ZTS builds ended with release v9.19.0.309.
  • New Relic recommends that you upgrade the agent regularly and at a minimum every 3 months. For more information on supported agent versions and EOL timelines, check out our PHP EOL policy.
  • The PHP agent compatibility and requirements page should be consulted for the latest information on supported PHP versions and platforms.

重要

For installations using an unsupported PHP version or platform (32 bit, FreeBSD, ZTS, etc), it's highly recommended that you disable the auto-update mechanisms for the PHP agent packages. This can be done by adding the PHP agent packages to an exclusion list for package upgrades. Or you could version pin the PHP agent package to an agent version that supports the old, unsupported feature(s). Failure to prevent upgrades may result in a newer agent release being installed and removal of support for the required, unsupported features. This would disrupt APM data collection. The PHP agent packages which are affected are:

  • newrelic-php5
  • newrelic-php5-common
  • newrelic-daemon

February 13, 2023
PHP agent v10.6.0.318

New Relic PHP Agent v10.6.0.318

New features

  • Code Level Metrics (CLM) is now enabled by default.
    • CLM allows you to gather more data associated with each span, including line numbers, function names, filepaths, and namespaces.
    • CLM was introduced in release 10.4.0.316.
    • Use this ini value to configure CLM.

Important end-of-life information

  • Support for PHP versions 5.5 and 5.6 will end June 2023.

Support statement

  • Support for 32 bit and FreeBSD ended with release v9.19.0.309 and those binaries are no longer provided.
  • Support for ZTS builds ended with release v9.19.0.309.
  • New Relic recommends that you upgrade the agent regularly and at a minimum every 3 months. For more information on supported agent versions and EOL timelines, check out our PHP EOL policy.
  • The PHP agent compatibility and requirements page should be consulted for the latest information on supported PHP versions and platforms.

重要

For installations using an unsupported PHP version or platform (32 bit, FreeBSD, ZTS, etc), it's highly recommended that you disable the auto-update mechanisms for the PHP agent packages. This can be done by adding the PHP agent packages to an exclusion list for package upgrades. Or you could version pin the PHP agent package to an agent version that supports the old, unsupported feature(s). Failure to prevent upgrades may result in a newer agent release being installed and removal of support for the required, unsupported features. This would disrupt APM data collection. The PHP agent packages which are affected are:

  • newrelic-php5
  • newrelic-php5-common
  • newrelic-daemon

January 18, 2023
PHP agent v10.5.0.317

New Relic PHP Agent v10.5.0.317

Bug Fixes

  • agent: Fixed #577 - Large performance regression in 10.3.0. #588
  • agent: Fixed #594 - Instrumentation from opcache.preload for PHP 8.1. #595
  • agent: Fixed sending Supportability/Logging/Forwarding/PHP/% and Supportability/Logging/Metrics/PHP/% application logging configuration metrics. #575

Support statement

  • Support for 32 bit and FreeBSD ended with release v9.19.0.309 and those binaries are no longer provided.
  • Support for ZTS builds ended with release v9.19.0.309.
  • New Relic recommends that you upgrade the agent regularly and at a minimum every 3 months. For more information on supported agent versions and EOL timelines, check out our PHP EOL policy.
  • The PHP agent compatibility and requirements page should be consulted for the latest information on supported PHP versions and platforms.

重要

For installations using an unsupported PHP version or platform (32 bit, FreeBSD, ZTS, etc), it's highly recommended that you disable the auto-update mechanisms for the PHP agent packages. This can be done by adding the PHP agent packages to an exclusion list for package upgrades. Or you could version pin the PHP agent package to an agent version that supports the old, unsupported feature(s). Failure to prevent upgrades may result in a newer agent release being installed and removal of support for the required, unsupported features. This would disrupt APM data collection. The PHP agent packages which are affected are:

  • newrelic-php5
  • newrelic-php5-common
  • newrelic-daemon

December 12, 2022
PHP agent v10.4.0.316

New Relic PHP Agent v10.4.0.316

重要

We recommend updating to the latest agent version as soon as it's available. If your organization has established practices that prevent you from upgrading to the latest version, ensure that your agents are regularly updated to a version at most 90 days old. Read more about keeping your agent up to date.

Important end-of-life information

  • Support for ZTS binaries was deprecated with release v9.17.0.300 and will be removed in a January 2023 release.

  • For installations using an unsupported PHP version or platform (32 bit, FreeBSD, ZTS, etc), it is highly recommended to disable the auto-update mechanisms for the PHP agent packages. This can be done by adding the PHP agent packages to an exclusion list for package upgrades. Alternatively, the PHP agent packages can be version pinned to an agent version that supports the old, unsupported feature(s). Failure to prevent upgrades may result in a newer agent release being installed, removing support for the required, unsupported features. This would disrupt APM data collection.
    The PHP agent packages which are affected are:

    • newrelic-php5
    • newrelic-php5-common
    • newrelic-daemon
  • You should check the PHP agent compatibility and requirements page for the latest information on supported PHP versions and platforms.

New features

  • Code Level Metrics (CLM) has been introduced and is set to off by default.
    • CLM allows you to gather more data associated with each span, including line numbers, function names, filepaths, and namespaces.
    • Use this ini value to start using CLM!

Improvements

  • Custom Event Limit default reservoir size has been increased and is now configurable.
    • The default maximum number of custom events gathered per minute has been increased from 10,000 to 30,000.
    • This value can now be modified with this ini value.

November 3, 2022
PHP agent v10.3.0.315

New Relic PHP Agent v10.3.0.315

重要

We recommend updating to the latest agent version as soon as it's available. If your organization has established practices that prevent you from upgrading to the latest version, ensure that your agents are regularly updated to a version at most 90 days old. Read more about keeping your agent up to date.

Important end-of-life information

  • Support for 32 bit and FreeBSD binaries were deprecated with release v9.19.0.309 and are no longer shipped starting with this release.

  • Support for ZTS binaries was deprecated with release v9.17.0.300 and will be removed in a release in the near future.

  • For installations using an unsupported PHP version or platform (32 bit, FreeBSD, ZTS, etc), it is highly recommended to disable the auto-update mechanisms for the PHP agent packages. This can be done by adding the PHP agent packages to an exclusion list for package upgrades. Alternatively, the PHP agent packages can be version pinned to an agent version that supports the old, unsupported feature(s). Failure to prevent upgrades may result in a newer agent release being installed, removing support for the required, unsupported features. This would disrupt APM data collection.
    The PHP agent packages which are affected are:

    • newrelic-php5
    • newrelic-php5-common
    • newrelic-daemon
  • The PHP agent compatibility and requirements page should be consulted for the latest information on supported PHP versions and platforms.

New features

Bug fixes

  • agent: Fix to ensure datastore segments do not create children segments. #511
  • agent: Updates instrumentation lookups for PHP 7.4+. Using reserved field of zend_func's op_array is no longer reliable as other extensions are unreliably using this shared area which then corrupts the opcache enough that it no longer provides lookups. The new method no longer relies on the agent storing any information in the reserved array of a zend_function. Fixes: Laravel 9 PHP8.1 Not reporting errors, All transactions are "unknown" bug

October 3, 2022
PHP agent v10.2.0.314

New Relic PHP Agent v10.2.0.314

New Features

  • newrelic-daemon: Informational messages will be logged if the number of connected applications falls below 25 or exceeds 200. #534

Bug Fixes

  • agent: Fixed SIGSEGV in Drupal 7 drupal_http_request instrumentation for PHP 7.4, 8.0 and 8.1. #538
  • agent: Fixed displaying newrelic.application_logging*.enabled value in PHP info output. #535
  • agent: When forwarding application logs, send the log message as a well-formed JSON string that is correctly escaped. #540
  • agent: Reduce the severity of a log message when an agent does not detect environmental variables. #539

Support statement

  • New Relic recommends that you upgrade the agent regularly and at a minimum every 3 months. For more information on supported agent versions and EOL timelines, check out our PHP EOL policy.

Copyright © 2024 New Relic株式会社。

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.