• EnglishEspañol日本語한국어Português
  • Inicia sesiónComenzar ahora

PHP agent release notesRSS

May 20
PHP agent v10.21.0.11

New Relic PHP agent v10.21.0.11

Bug fixes

Security updates

Important end-of-life information

  • Support for PHP versions 7.0 and 7.1 will EOL on June 1st, 2024

Support statement

  • New Relic recommends that you upgrade the agent regularly and at a minimum every 3 months. For more information on supported agent versions and EOL timelines, check out our PHP EOL policy.
  • The PHP agent compatibility and requirements page should be consulted for the latest information on supported PHP versions and platforms.

Importante

For installations using an unsupported PHP version or platform, it's highly recommended that you disable the auto-update mechanisms for the PHP agent packages. This can be done by adding the PHP agent packages to an exclusion list for package upgrades. Or you could version pin the PHP agent package to an agent version that supports the old, unsupported feature(s). Failure to prevent upgrades may result in a newer agent release being installed and the removal of support for the required, unsupported features. This would disrupt APM data collection.

The PHP agent packages that are affected are:

  • newrelic-php5
  • newrelic-php5-common
  • newrelic-daemon

May 6
PHP agent v10.20.0.10

New Relic PHP agent v10.20.0.10

New features

  • Add support for Yii v2 framework
  • Verified support for Drupal 10 framework
  • Add supportability metrics for PHP packages that provide major version
  • Update default for newrelic.framework.wordpress.hooks.options to "plugin_callbacks"

Bug fixes

  • Fix error reporting for errors converted by PHP to exceptions
  • Improve user exception handler instrumentation for PHPs 8.0+
  • Fix warning from mysqli when explaining slow SQL queries
  • Fix json struct tag for docker id
  • Improve communications of PHP packages data to the backend

Security

  • Bump google.golang.org/protobuf from 1.32.0 to 1.33.0 in newrelic-daemon
  • Bump golang.org/x/net from 0.20.0 to 0.23.0 in newrelic-daemon

Important end-of-life information

  • Support for PHP versions 7.0 and 7.1 will EOL on June 1st, 2024

Support statement

  • New Relic recommends upgrading the agent regularly and at least every 3 months. For more information on supported agent versions and EOL timelines, check out our PHP EOL policy.
  • For the latest information on supported PHP versions and platforms, consult the PHP agent compatibility and requirements page.

Importante

For installations using an unsupported PHP version or platform, it's highly recommended that you disable the auto-update mechanisms for the PHP agent packages. This can be done by adding the PHP agent packages to an exclusion list for package upgrades. Or you could version pin the PHP agent package to an agent version that supports the old, unsupported feature(s). Failure to prevent upgrades may result in a newer agent release being installed and the removal of support for the required, unsupported features. This would disrupt APM data collection.

The PHP agent packages that are affected are:

  • newrelic-php5
  • newrelic-php5-common
  • newrelic-daemon

March 18
PHP agent v10.19.0.9

New Relic PHP agent v10.19.0.9

New features

  • Always link error traces using transaction ID

Bug fixes

  • Fixes a bug where the agent would not properly automatically detect the Magento 2 framework
  • Fixes error categorization and prioritization by adding support for E_RECOVERABLE_ERROR, E_DEPRECATED, E_USER_DEPRECATED error types. E_RECOVERABLE_ERROR, E_DEPRECATED, E_USER_DEPRECATED are no longer recorded as Error.
  • Fixes error recording for PHPs 8.0+: user_error_handler is honored, and the agent will not record an error if user_error_handler handled the error.

Important end-of-life information

  • Support for PHP versions 7.0 and 7.1 will EOL on June 1st, 2024

Support statement

  • New Relic recommends that you upgrade the agent regularly and at a minimum every 3 months. For more information on supported agent versions and EOL timelines, check out our PHP EOL policy.
  • The PHP agent compatibility and requirements page should be consulted for the latest information on supported PHP versions and platforms.

Importante

For installations using an unsupported PHP version or platform, it's highly recommended that you disable the auto-update mechanisms for the PHP agent packages. This can be done by adding the PHP agent packages to an exclusion list for package upgrades. Or you could version pin the PHP agent package to an agent version that supports the old, unsupported feature(s). Failure to prevent upgrades may result in a newer agent release being installed and the removal of support for the required, unsupported features. This would disrupt APM data collection. The PHP agent packages that are affected are:

  • newrelic-php5
  • newrelic-php5-common
  • newrelic-daemon

March 4
PHP agent v10.18.0.8

New Relic PHP agent v10.18.0.8

New features

  • PHP's Just-In-Time Compilation is no longer disabled when the PHP Agent is enabled. PHP has this on-by-default starting with PHP 8.0.

Bug fixes

  • Fixes a bug where the agent would not properly automatically detect the Lumen framework

Important end-of-life information

  • Support for PHP versions 7.0 and 7.1 will EOL on June 1st, 2024

Support statement

  • New Relic recommends that you upgrade the agent regularly and at a minimum every 3 months. For more information on supported agent versions and EOL timelines, check out our PHP EOL policy.
  • The PHP agent compatibility and requirements page should be consulted for the latest information on supported PHP versions and platforms.

Importante

For installations using an unsupported PHP version or platform, it's highly recommended that you disable the auto-update mechanisms for the PHP agent packages. This can be done by adding the PHP agent packages to an exclusion list for package upgrades. Or you could version pin the PHP agent package to an agent version that supports the old, unsupported feature(s). Failure to prevent upgrades may result in a newer agent release being installed and the removal of support for the required, unsupported features. This would disrupt APM data collection. The PHP agent packages that are affected are:

  • newrelic-php5
  • newrelic-php5-common
  • newrelic-daemon

February 21
PHP agent v10.17.0.7

New Relic PHP agent v10.17.0.7

New features

  • The PHP agent now sends up package detection information that can be viewed on the environment page. This feature will be enabled by default and you can find more information about this INI configuration here.

Bug fixes

  • Fixes a locale bug in DT W3C trace state header generation

Important end-of-life information

  • Support for PHP versions 7.0 and 7.1 will EOL on June 1st, 2024

Support statement

  • New Relic recommends that you upgrade the agent regularly and at a minimum every 3 months. For more information on supported agent versions and EOL timelines, check out our PHP EOL policy.
  • The PHP agent compatibility and requirements page should be consulted for the latest information on supported PHP versions and platforms.

Importante

For installations using an unsupported PHP version or platform, it's highly recommended that you disable the auto-update mechanisms for the PHP agent packages. This can be done by adding the PHP agent packages to an exclusion list for package upgrades. Or you could version pin the PHP agent package to an agent version that supports the old, unsupported feature(s). Failure to prevent upgrades may result in a newer agent release being installed and the removal of support for the required, unsupported features. This would disrupt APM data collection. The PHP agent packages that are affected are:

  • newrelic-php5
  • newrelic-php5-common
  • newrelic-daemon

January 23
PHP agent v10.16.0.5

New Relic PHP agent v10.16.0.5

Security

  • Agent debugging log obfuscation improved for relevant agent configuration values.

New features

Miscellaneous improvements

  • Several performance-related improvements for agent when using the Wordpress framework.

Important end-of-life information

  • Support for PHP versions 7.0 and 7.1 will EOL on June 1st, 2024

Support statement

  • New Relic recommends that you upgrade the agent regularly and at a minimum every 3 months. For more information on supported agent versions and EOL timelines, check out our PHP EOL policy.
  • The PHP agent compatibility and requirements page should be consulted for the latest information on supported PHP versions and platforms.

Importante

For installations using an unsupported PHP version or platform, it's highly recommended that you disable the auto-update mechanisms for the PHP agent packages. This can be done by adding the PHP agent packages to an exclusion list for package upgrades. Or you could version pin the PHP agent package to an agent version that supports the old, unsupported feature(s). Failure to prevent upgrades may result in a newer agent release being installed and the removal of support for the required, unsupported features. This would disrupt APM data collection. The PHP agent packages that are affected are:

  • newrelic-php5
  • newrelic-php5-common
  • newrelic-daemon

December 20, 2023
PHP agent v10.15.0.4

New Relic PHP agent v10.15.0.4

New features

  • Adds support for PHP 8.3

Bug fixes

  • Removes a warning message for NULL Docker ID

Miscellaneous improvements

  • Several performance-related improvements

Important end-of-life information

  • Support for PHP versions 7.0 and 7.1 will EOL on June 1st, 2024

Support statement

  • New Relic recommends that you upgrade the agent regularly and at a minimum every 3 months. For more information on supported agent versions and EOL timelines, check out our PHP EOL policy.
  • The PHP agent compatibility and requirements page should be consulted for the latest information on supported PHP versions and platforms.

Importante

For installations using an unsupported PHP version or platform, it's highly recommended that you disable the auto-update mechanisms for the PHP agent packages. This can be done by adding the PHP agent packages to an exclusion list for package upgrades. Or you could version pin the PHP agent package to an agent version that supports the old, unsupported feature(s). Failure to prevent upgrades may result in a newer agent release being installed and the removal of support for the required, unsupported features. This would disrupt APM data collection. The PHP agent packages that are affected are:

  • newrelic-php5
  • newrelic-php5-common
  • newrelic-daemon

November 13, 2023
PHP agent v10.14.0.3

New Relic PHP agent v10.14.0.3

Security

  • Updated the Golang version used to build the Daemon from 1.20 to 1.21.1.

New features

  • The PHP agent now supports APM log context attributes. See the PHP Logs In Context page for more information.

  • The agent now supports detecting Docker container IDs via cgroup v2.

Bug fixes

  • A fix was added that removes erroneous deprecation warnings which could appear using the mysqli extension with PHP 8.1 and later.

  • When PHP 8+ is built in debug mode, zpp/arginfo mismatches are now Fatal Errors. Fixed the mismatches that existed in the code base.

  • Resolved an issue impacting duplicative telemetry data.

Important end-of-life information

  • Support for PHP versions 7.0 and 7.1 will EOL in early 2024.

Support statement

  • New Relic recommends that you upgrade the agent regularly and at a minimum every 3 months. For more information on supported agent versions and EOL timelines, check out our PHP EOL policy.
  • The PHP agent compatibility and requirements page should be consulted for the latest information on supported PHP versions and platforms.

Importante

For installations using an unsupported PHP version or platform, it's highly recommended that you disable the auto-update mechanisms for the PHP agent packages. Failure to prevent upgrades may result in a newer agent release being installed and the removal of support for the required, unsupported features. This would disrupt APM data collection. This can be done by adding the PHP agent packages to an exclusion list for package upgrades. Or you could version pin the PHP agent package to an agent version that supports the old, unsupported feature(s). The PHP agent packages that are affected are:

  • newrelic-php5
  • newrelic-php5-common
  • newrelic-daemon

October 3, 2023
PHP agent v10.13.0.2

New Relic PHP agent v10.13.0.2

New features

Important end-of-life information

  • Support for PHP versions 7.0 and 7.1 will EOL in early 2024.

Support statement

  • New Relic recommends that you upgrade the agent regularly and at a minimum every 3 months. For more information on supported agent versions and EOL timelines, check out our PHP EOL policy.
  • The PHP agent compatibility and requirements page should be consulted for the latest information on supported PHP versions and platforms.

Importante

For installations using an unsupported PHP version or platform, it's highly recommended that you disable the auto-update mechanisms for the PHP agent packages. This can be done by adding the PHP agent packages to an exclusion list for package upgrades. Or you could version pin the PHP agent package to an agent version that supports the old, unsupported feature(s). Failure to prevent upgrades may result in a newer agent release being installed and the removal of support for the required, unsupported features. This would disrupt APM data collection. The PHP agent packages that are affected are:

  • newrelic-php5
  • newrelic-php5-common
  • newrelic-daemon

September 20, 2023
PHP agent v10.12.0.1

New Relic PHP agent v10.12.0.1

New features

  • Improved Guzzle 5 and 6 detection.
  • Adds newrelic_set_error_group_callback API, allowing an application to register a callback function with the PHP Agent that will generate a custom error group name. Read more about this API here.
  • Adds newrelic_set_user_id API, allowing an application to assign a unique user ID to a transaction. Read more about this API here.
  • Adds a link to documentation to the install error message when installing an unsupported version of PHP.
  • Verified support for Guzzle 7.
  • Verified support for Laravel 9 and 10.

Bug fixes

  • Reduces the log level for a Drupal-specific message to a more appropriate value.
  • Fixes a bug in Infinite Tracing where distributed traces were missing a parentID attribute that caused issues displaying a distributed application in the UI.

Important end-of-life information

  • Support for PHP versions 7.0 and 7.1 will EOL in early 2024.

Support statement

  • New Relic recommends that you upgrade the agent regularly and at a minimum every 3 months. For more information on supported agent versions and EOL timelines, check out our PHP EOL policy.
  • The PHP agent compatibility and requirements page should be consulted for the latest information on supported PHP versions and platforms.

Importante

For installations using an unsupported PHP version or platform, it's highly recommended that you disable the auto-update mechanisms for the PHP agent packages. This can be done by adding the PHP agent packages to an exclusion list for package upgrades. Or you could version pin the PHP agent package to an agent version that supports the old, unsupported feature(s). Failure to prevent upgrades may result in a newer agent release being installed and the removal of support for the required, unsupported features. This would disrupt APM data collection. The PHP agent packages that are affected are:

  • newrelic-php5
  • newrelic-php5-common
  • newrelic-daemon

Copyright © 2024 New Relic Inc.

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.