Supported browsers for New Relic's UI

New Relic's user interface supports most browser types. The UI shows an error notification if you use an unsupported browser version.

For the requirements for the New Relic Browser product, see Compatibility and requirements for New Relic Browser.

Requirements

Our UI supports the two most recent desktop versions of the following browsers:

  • Google Chrome: Linux, Mac, Windows
  • Mozilla Firefox: Linux, Mac, Windows
  • Microsoft Edge: Windows
  • Apple Safari: Mac

In addition, our UI provides limited support for the following browsers:

  • Internet Explorer 11: Supported on Windows for some UIs. The New Relic One UI does not support IE 11.
  • Mobile browsers: The best way to access New Relic from a mobile device is our Android app or iOS app. The web interface is not actively supported on mobile browsers.

Troubleshooting tips

If you are using a supported browser version and have problems with the site:

  1. Check your browser settings.
  2. Try adjusting your monitor size or resolution.

If your browser version is not supported, it may still work. However, to get the best functionality, New Relic encourages you to upgrade to a supported version.

For more help

Recommendations for learning more: