• English日本語한국어
  • Log inStart now

Android agent release notesRSS

November 15
Android agent v7.2.0

New

Adds configurable request header instrumentation to network events

The agent will now produce network event attributes for select header values if the headers are detected on the request. The header names to instrument are passed into the agent when started.

For more information, see Adding Tracked Headers in the Mobile Monitoring documentation.

Adds GraphQL attributes to network events

If the agent detects request headers from Apollo GraphQL servers, it will add additional attributes to the network request event.

For more information, see Adding Tracked Headers in the Mobile Monitoring documentation.

Exclude instrumentation by package name

The agent plugin can now be configured to exclude classes from a specific package space during instrumentation. These classes will be unmodified. This feature can be useful when encountering sensitive or problematic class data.

For more information, see Configure the New Relic Gradle plugin.

Fixed

  • Exclude signed jars from instrumentation

Support statement

We recommend you to upgrade the agent at least every 3 months. The specific policies and dates for Android agent support of the can be found in the Mobile monitoring agents EOL policy.

October 19
Android NDK agent v1.0.4

Fixed

  • Fixed a memory leak when ANRMonitor is enabled.

Support statement

The Android NDK agent version 1.0.3 and above requires Android agent 6.11.0 and higher. Versions 1.0.0 - 1.0.2 are compatible with Android agent 6.10.0 and lower.

We recommend you to upgrade the agent regularly, at least every 3 months.

September 25
Android agent v7.1.0

New

  • Adds support for DexGuard 9+ with Gradle 8/AGP 8
  • Adds unity support with custom exceptions
  • Adds map parameters for both custom and auto HTTP instrumentation to ensure data accuracy
  • Decouple map tagging with uploads in plugin to improve the build pipeline by making the tagged map a cachable build artifact

Fixed

  • Fix NoClassDefFoundError when using agent v7.0.0 due to uninstrumented signed libraries
  • Fix an issue that excludeVariantInstrumention is not accepting camel case variant names

Support statement

We recommend you to upgrade the agent regularly, at least every 3 months.

As of this release, the oldest supported version is 6.3.0.

July 19
Android NDK agent v1.0.3

Fixed

  • Fixed java.lang.NoSuchMethodError when using the NDK agent and Android agent version 6.11.0 and higher.

Support statement

The Android NDK agent version 1.0.3 requires Android agent 6.11.0 and higher. Versions 1.0.0 - 1.0.2 are compatible with Android agent 6.10.0 and lower.

We recommend you to upgrade the agent regularly, at least every 3 months.

July 10
Android agent v7.0.0

Important

Welcome to the New Relic Android agent version 7.0. This major release breaks compatibility with versions of

  • Gradle 6.x

  • Android Gradle Plugin (AGP) 4.x

    Android agent 7.x is increasing the minimum Gradle version to 7.1. Customers will be required to upgrade to Android Gradle Plugin (AGP) 7.0.0 and higher.

New

  • Adds support for Gradle 8.0 and higher
  • Adds support for the Android Gradle Plugin 8.0 and higher
  • Adds support for Gradle configuration caching
  • Adds support for JDK 17 when used with Gradle 8

Support statement

We recommend you to upgrade the agent regularly, at least every 3 months.

As of this release, the oldest supported version is 6.1.0.

May 16
Android agent v6.11.1

Fixed

  • Fix an issue of app crashes when goes to background after agent shutdown

Support statement

We recommend you to upgrade the agent regularly, at least every 3 months.

As of this release, the oldest supported version is 6.1.0.

Important

Please note, the Android agent will be increasing the minimum Gradle versions in agent release 6.12.0. Customers will be required to upgrade to Android Gradle Plugin 7.2 or higher.

May 10
Android agent v6.11.0

New

  • Add FedRAMP support

Fixed

  • Fix an issue of NR_BUILD_ID not appending with default release variant
  • Tighten the exception handling of TraceMachine to prevent NullPointerException

Support statement

We recommend you to upgrade the agent regularly, at least every 3 months.

As of this release, the oldest supported version is 6.1.0.

Important

Please note, the Android agent will be increasing the minimum Gradle versions in agent release 6.12.0. Customers will be required to upgrade to Android Gradle Plugin 7.2 or higher.

May 4
Android NDK agent v1.0.2

Fixed

  • Updated Kotlin library to a version that addressed a vulnerability.

Support statement

We recommend you to upgrade the agent regularly, at least every 3 months.

April 10
Android NDK agent v1.0.1

Fixed

  • Addressed a memory leak resulting from ANR detection

Support statement

We recommend you to upgrade the agent regularly, at least every 3 months.

March 9
Android agent v6.10.0

New

  • Add a new feature to provide the ability to disable agent at runtime

Fixed

  • Fix an issue of failing to report network failure
  • Tighten the exception handling of HarvestTimer.tickNow() to prevent NullPointerException

Support statement

We recommend you to upgrade the agent regularly, at least every 3 months.

As of this release, the oldest supported version is 6.0.0.

Important

Please note, the Android agent will be increasing the minimum Gradle versions in agent release 6.12.0. Customers will be required to upgrade to Android Gradle Plugin 7.2 or higher.

Copyright © 2023 New Relic Inc.

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.