• /
  • Log in
  • Free account

Ruby agent v6.15.0

January 19, 2021Download

v6.15.0

  • Official Ruby 3.0 support

    The Ruby agent has been verified to run on Ruby 3.0.0.

  • Added support for Rails 6.1

    The Ruby agent has been verified to run with Rails 6.1. Special thanks to @hasghari for setting this up!

  • Added support for Sidekiq 6.0, 6.1

    The Ruby agent has been verified to run with both 6.0 and 6.1 versions of sidekiq.

  • Bugfix: No longer overwrites sidekiq trace data

    Distributed tracing data is now added to the job trace info rather than overwriting the existing data.

  • Bugfix: Fixes cases where errors are reported for spans with no other attributes

    Previously, in cases where a span does not have any agent/custom attributes on it, but an error is noticed and recorded against the span, a FrozenError: can't modify frozen Hash is thrown. This is now fixed, and errors are now correctly recorded against such span events.

  • Bugfix: DistributedTracing.insert_distributed_trace_headers Supportability metric now recorded

    Previously, API calls to DistributedTracing.insert_distributed_trace_headers would lead to an exception about the missing supportability metric rather than flowing through the API implementation as intended. This would potentially lead to broken distributed traces, as the trace headers were not inserted on the API call. DistributedTracing.insert_distributed_trace_headers now correctly records the supportability metric and inserts the distributed trace headers as intended.

  • Bugfix: child completions after parent completes sometimes throws exception attempting to access nil parent

    In scenarios where the child segment/span is completing after the parent in jRuby, the parent may have already been freed and no longer accessible. This would lead to attempting to calll descendant_complete on a nil object. This is fixed to protect against calling the descendant_complete in these cases.

  • Feature: implements force_install_exit_handler config flag

    The force_install_exit_handler configuration flag allows an application to instruct the agent to install its graceful shutdown exit handler. This sends any locally cached data to the New Relic collector before the application shuts down. This is useful when the primary framework has an embedded Sinatra application that is otherwise detected and skips installing the exit hook for graceful shutdowns.

  • Default prepend_net_instrumentation to false

    Previously, prepend_net_instrumentation defaulted to true. However, many gems are still using monkey patching on Net::HTTP, which causes compatibility issues with using prepend. Defaulting this to false minimizes instances of unexpected compatibility issues.

  • Infinite tracing adds additional data to connection metadata

    Adds data from the agents connect response request_headers_map to the metadata for the connection to the infinite trace observer.

Support statement

New Relic recommends that you upgrade the agent regularly and at a minimum every 3 months. As of this release, the oldest supported version is 4.8.0.

Create issueEdit page
Copyright © 2021 New Relic Inc.