BREAKING: Updated the version of
https-proxy-agentto v2.x - Dropped support for v0.10 and v0.12 of node.
The version of
https-proxy-agentused in the agent has a known security issue you can read about here: https://snyk.io/vuln/npm:https-proxy-agent:20180402 In order to resolve this issue, the dependency had to be updated to at least v2.2.0, which only supported node versions >=4. The update to this dependency forces the incompatibility of the agent with versions 0.10 and 0.12 of node.
In order to use use the Node.js agent, please upgrade node to version >=4, or you can continue to use the agent on node versions 0.10 and 0.12 by pinning the agent to v3.
You can read more about the issue here: https://docs.newrelic.com/docs/using-new-relic/new-relic-security/securi...
Node.js agent v4.0.0
April 12, 2018