Not seeing Infrastructure integration data

Problem

You created a custom integration for New Relic Infrastructure, but you are not seeing data in the New Relic Infrastructure UI.

Solution

To troubleshoot and resolve the problem:

  1. Verify that your integration meets New Relic Infrastructure's integration requirements.
  2. After ruling out common problems with integration requirements, follow the more in-depth troubleshooting procedures for error logs and integration loading.
Troubleshoot integration requirements

If you are not receiving data from your custom integration, verify that your integration follows these requirements.

Integration requirements Comments
Environment Make sure your environment meets the Integrations SDK requirements.
Configuration file
  1. Use a validator such as yamllint to verify that the configuration file is a valid YAML file.
  2. Verify that the file is in the correct location.
Definition file
  1. Use a validator such as yamllint to verify that the definition file is a valid YAML file.
  2. Verify that the header fields have the required format.
  3. Verify that the prefix for inventory set in the definition file is no more than two levels deep.
  4. Verify that the file is in the correct location.
Metric sets

Verify that the integration:

  • Does not generate metric sets with more than 120 key-value pairs.
  • Does not generate more than 1000 metric sets.
JSON payload Verify that the integration does not generate a single JSON payload of more than 5 MB.
Check the integration log file for error messages

After ruling out common problems with integration requirements, follow these more in-depth troubleshooting procedures.

Recommendation: Configure a log file in the Infrastructure agent configuration. This helps separate the types of errors so you can spot integration errors more easily.

When there is an error loading or running your integration, the Infrastructure agent adds an error message to the log file. Errors are logged even if verbose mode is disabled.

  1. Check the log file for lines that include "level=error".
  2. If there are no error messages, check whether the Infrastructure agent is loading the integration correctly.
Check that the integration is loading correctly

To verify whether the Infrastructure agent is loading the integration correctly:

  1. Enable verbose mode in the Infrastructure agent configuration.
  2. Restart the Infrastructure agent.
  3. Verify that the first lines of the log file contain two messages:

    "loaded plugin" plugin=<your_integration_name>
    "found plugin config file" plugin-path="<your_integration_config_path>"
  4. Check for errors just before or after these lines that indicate a problem with loading.

The agent schedules data to be sent based on the schedule set in the definition file. Look in the log file for the integration's JSON.

JSON payload example

nginx-server-metrics: {\"name\":\"com.newrelic.nginx\",\"protocol_version\":\"1\",\"integration_version\":\"0.5.0\",\"metrics\":
[{\"event_type\":\"NginxSample\",\"net.connectionsAcceptedPerSecond\":0.10344827586206896,\"net.connectionsActive\":1,
\"net.connectionsDroppedPerSecond\":0,\"net.connectionsReading\":0,\"net.connectionsWaiting\":0,\"net.connectionsWriting\":1,
\"net.requestsPerSecond\":0.10344827586206896,\"software.edition\":\"open source\",\"software.version\":\"1.4.6 (Ubuntu)\"}],\"inventory\":{},\"events\":[]}

For more help

Recommendations for learning more: