Problem
The agent is working but some of the metadata or inventory data appears incorrect, and the local caching is preventing correct data to be sent from the infrastructure agent.
Solution Linux
Stop the Infrastructure Agent
sudo systemctl stop newrelic-infra
Delete temporary files
sudo rm -rf /var/db/newrelic-infra/data
Start the Infrastructure Agent
sudo systemctl start newrelic-infra
Solution Windows
In an Administrator PowerShell prompt, stop the Infrastructure Agent
net stop newrelic-infra
Delete temporary files
Remove-Item -Path โC:\ProgramData\New Relic\newrelic-infra\dataโ -Recurse -Force
Start the Infrastructure Agent
net start newrelic-infra
Cause
The agent caches metadata & inventory data locally, to determine what delta to send. In some situations, it might be desired to reset this local cache / state, so that all data is sent accross.