Java SE 5.0 support

Sun/Oracle released Java SE 5.0 (aka JDK 1.5) in 2004 and Java SE 6 in 2006. It has not provided a public update to 5.0 since 2009, and ceased Extended support in May 2015.

Java SE options

This describes New Relic's requirements for using SE 5 or higher:

  • If you want to use New Relic's latest Java agent 3.x (which includes the latest New Relic features), you must upgrade to Java SE 6 or higher. For more information and installation instructions, refer to the Java agent Release Notes.
  • If you want to continue using Java SE 5.0, you must use the most recent version of Java agent 2.x. Java agent 2.x does not have the latest New Relic features.

Java agent 2.x installation

Download [ZIP | 2.8 MB] the most recent New Relic Java agent that supports Java SE 5.0. This download does not add your license key to your newrelic.yml file. You will need to manually edit the license_key setting.

For installation instructions, see Manual Java agent installation.

For more help

New Relic continues to provide excellent technical support for customers running Java agent 2.x on Java SE 5.0, including patch releases for critical fixes. However, Java agent 2.x will not have the latest New Relic features.

Recommendations for learning more: