IBM WebSphere Application Server

This describes how to configure New Relic's Java agent if you are using IBM WebSphere Application Server. For compatible versions, follow New Relic's procedures to install the Java agent on WebSphere.

IBM WebSphere App Server Comments
Compatible IBM JVM versions

New Relic supports all versions of WebSphere that are compatibile with the Java agent. However, certain versions of the IBM JVM are incompatible with the Java agent due to known issues in the IBM JVM.

New Relic's Java agent is compatible with these major versions of the IBM JVM:

  • 8: All versions
  • 7: Version 7.0.0 SR3 or higher
  • 6: Version 6.0.1 SR4 or higher
Java 2 Security

If you are using Java 2 Security and WebSphere, you must grant the Java agent additional permissions before it can execute properly.

New Relic Browser

To use New Relic Browser monitoring when running the Java agent on WebSphere, you must manually enable Browser monitoring.

WebSphere PMI metrics

You can configure the Java agent to capture additional WebSphere PMI metrics. These metrics will appear on the New Relic JVM metrics page.

Instance and display names

You can configure the Java agent to change the default behavior of instance names or display names.

For more help

Recommendations for learning more: