문제
앱에 대한 트래픽을 생성하고 5분을 기다리면 .NET 에이전트 데이터가 New Relic UI에 표시되지 않습니다.
해결책
데이터 부재는 여러 가지 이유로 발생할 수 있습니다.
Common causes
누락된 데이터의 경우: 기본 문제 해결 방법을 참조하세요.
Other situations:
기본 솔루션으로 문제가 해결되지 않으면 데이터 부족이 시스템에 더 본질적일 수 있습니다. 자세한 내용은 고급 문제 해결 솔루션을 참조하세요.
Microsoft Azure users:
Azure 문제 해결 솔루션을 참조하세요.
No browser data appears:
브라우저 에이전트 사용 시 문제 해결 팁을 참조하세요.
기본 솔루션
데이터 누락의 가장 일반적인 원인을 해결하려면 해당하는 솔루션을 시도해 보십시오.
Basic solutions | Comments |
---|---|
에이전트와의 호환성을 위해 앱 및 프레임워크 확인 | 또는 |
일반적인 설치 문제에 대해 알아보기 | .NET Core 및 Linux 문제 해결 또는 Windows 문제 해결을 참조하세요. |
단기 .NET 프로세스 구성 | 수명이 짧은(60초 미만) 프로세스가 있는 경우 데이터를 보고하지 않을 수 있습니다. 자세한 내용은 단기 프로세스 모니터링 을 참조하세요. |
.NET Core: Kestrel 요구 사항을 확인하세요. | New Relic에서 지원하는 Kestrel 앱/웹 서버 를 사용하고 있는지 확인하세요. 그렇지 않으면 .NET 에이전트에 .NET Framework 지원 이 활성화되어 있는지 확인해야 할 수 있습니다. |
.NET Core: 환경변수를 확인해보세요. | 필요한 모든 환경 변수 를 구성했는지 확인한 다음 에이전트를 다시 시작하십시오. |
.NET Framework: IIS를 다시 시작하십시오. | 앱이 트래픽을 수신하지 않으면 New Relic에 데이터가 보고되지 않습니다. IIS를 다시 시작하려면:
|
새 유물 진단을 실행합니다. | 문제를 자동으로 식별하려면 New Relic Diagnostics 를 사용하십시오. |
프로파일러 충돌 을 확인하십시오. | Microsoft의 SCOM(System Center Operations Manager)을 사용하는 경우 문제 해결 절차에 따라 .NET 및 SCOM 충돌 을 해결하십시오. |
로그 파일을 검토합니다. | 로그 파일 이 있으면 열어서 오류를 검토하십시오. |
고급 솔루션
데이터가 표시되지 않을 때 더 복잡한 문제를 해결하려면 해당하는 경우 다음 솔루션을 시도하십시오.
Advanced solutions | Comments |
---|---|
.NET Framework: 레지스트리 권한을 확인하세요. | 레지스트리 키 권한 오류 를 확인하십시오. |
.NET Framework: Windows 이벤트 뷰어를 실행합니다. | 적용된다면:
|
디버그 로그를 가져옵니다. | 로그에 오류가 표시되지 않으면 일시적으로 로깅 수준을 높여 |
프록시 설정을 확인하십시오. | 프록시 설정 이 올바르고 설정에 호스트 속성이 포함되어 있는지 확인하십시오. |
.NET 8: 런타임 진단이 활성화되어 있는지 확인하세요 | .NET 8부터 환경 변수 |
추가 도움을 받으세요. | 데이터가 여전히 나타나지 않으면 support.newrelic.com 에서 지원을 받으십시오. |