문제
Java 앱의 로그 데이터 에 New Relic 연결 실패가 표시됩니다. INFO
메시지가 트래픽 연결이나 방화벽 규칙 때문인지 아니면 더 심각한 문제 때문인지 확인하려고 합니다.
해결책
New Relic 수집기 에 연결하는 데 가끔 실패하더라도 걱정할 필요가 없습니다. 이러한 실패는 앱의 New Relic 사용자 인터페이스에서 사용할 수 있는 성능 측정항목에 영향을 주지 않아야 합니다.
New Relic의 Java 에이전트는 1분에 한 번 정도 연결을 시도합니다. 문제를 해결하려면:
- 연결 실패에 대한
INFO
메시지에 대한 로그 파일을 검색하십시오. - 메시지가 얼마나 자주 나타나는지 확인하십시오.
예를 들어 다음과 같은 메시지를 찾습니다.
Jul 31, 2017 21:37:14 +0000 NewRelic 10INFO: Failed to connect to collector.newrelic.com.:443 for My Application:java.net.ConnectException: Connection refused:connect
또는
Jul 31, 2017 21:37:14 +0000 NewRelic 40INFO: The data collector is temporarily unavailable.This can happen periodically. In the event that availability of our servers is not restored after a period of time, then please report this to New Relic.java.net.SocketException: Connection reset
메시지가 나타나는 빈도에 따라 다음을 수행하여 문제를 해결하십시오.
Frequency of INFO message | Comments |
---|---|
몇 분 | 뉴렐릭의 저항력은 연결이 불가능할 때 상당한 양의 지표 데이터를 캐시할 수 있습니다. 중단이 몇 분 동안 지속되더라도 일반적으로 이로 인해 UI의 정보가 손실되지는 않습니다. 이러한 메시지는 무시해도 됩니다. |
며칠에 걸쳐 간헐적으로 | 간헐적인 연결 문제로 인해 짧은 시간에 이러한 메시지가 많이 발생할 수 있습니다. 이것이 며칠에 한 번만 발생하고 모든 앱 데이터가 New Relic UI에 나타나면 이 메시지를 무시해도 됩니다. |
몇 분 동안 매분 | 몇 분 이상 동안 1분마다 오류가 발생하면 Java 에이전트가 앱에서 데이터를 수신할 수 없으며 데이터가 보고될 수 없습니다. 이러한 상황에서:
|
원인
로그 텍스트에도 불구하고 이 오류는 일반적으로 New Relic 수집기를 실제로 사용할 수 없는 것이 아니라 연결 실패 또는 방화벽 트래픽으로 인해 발생합니다. 자세한 내용은 New Relic의 모든 서비스에서 사용하는 IP 범위 목록을 참조하세요.