• English日本語한국어
  • ログイン今すぐ開始

Deprecation notice: Kubernetes

November 15, 2023

Effective Wednesday, November 15, 2023, our Kubernetes integration drops support for Kubernetes v1.23 and lower. The Kubernetes integration v3.20.0 and higher will only be compatible with Kubernetes versions 1.24 and higher. For more information, read this note or contact your account team.

Background

Enabling compatibility with the latest Kubernetes versions and adding new features to our Kubernetes offering prevents us from offering first-class support to versions v1.23 and lower.

What's happening

  • Most major Kubernetes cloud providers have already deprecated v1.23 and lower.

What do you need to do

It's easy: Upgrade your Kubernetes clusters to a supported version.

What happens if you don't make any changes to your account

The Kubernetes integration may continue to work with end-of-lifed versions. However, we can't guarantee the quality of the solution as new releases may cause some incompatibilities.

Please note that we won't accept support requests for these versions that have reached the end of their life.

Copyright © 2024 New Relic Inc.

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.