• ログイン今すぐ開始

Deprecation notice: Kubernetes

December 16, 2021

Effective Monday, 1 January 2022, our Kubernetes integration drops support for Kubernetes v1.15 and lower. The Kubernetes integration v2.8.0 and higher will only be compatible with Kubernetes versions 1.16 and higher. For more information, read this note or contact your account team.

Background

Enabling compatibility with the latest Kubernetes versions and adding new features to our Kubernetes offering prevents us from offering first-class support to versions prior to v1.16.

What is happening?

  • The latest Kubernetes version v1.22 has API incompatibilities with versions prior to v1.16.
  • Most major Kubernetes cloud providers have already deprecated v1.15 and lower.

What do you need to do?

It's easy: Upgrade your Kubernetes clusters to a supported version.

What happens if you don't make any changes to your account?

The Kubernetes integration may continue to work with end-of-lifed versions. However, we can't guarantee the quality of the solution as new releases may cause some incompatibilities.

Note that support requests regarding these end-of-lifed versions won't be accepted.

Copyright © 2022 New Relic株式会社。