• EnglishEspañol日本語한국어Português
  • ログイン今すぐ開始

Infrastructure agent release notesRSS

July 18, 2023
Infrastructure agent v1.44.0

A new version of the agent has been released. Follow standard procedures to update the infrastructure agent.

We recommend that you update the agent regularly and at a minimum every three months. As of this release, the oldest supported version is infrastructure agent 1.27.5.

Added

Changed

  • Disable CGO for amd64 #1689
  • Bump dependency newrelic/nri-prometheus to v2.18.5 #1696
  • Bump dependency newrelic/nri-docker to v1.8.9 #1695

Fixed

  • Fallback to td-agent-bit when fluent-bit not present #1694

July 11, 2023
Infrastructure agent v1.43.2

A new version of the agent has been released. Follow standard procedures to update the infrastructure agent.

New Relic recommends that you upgrade the agent regularly and at a minimum every three months. As of this release, the oldest supported version is Infrastructure agent 1.27.4.

Changed

  • Validate NTP responses #1684
  • Bump Go patch version to v1.19.10 #1683
  • Bump newrelic/nri-docker to v1.8.7 #1685
  • Bump newrelic/nri-flex to v1.8.6 #1686

June 23, 2023
Infrastructure agent v1.43.1

A new version of the agent has been released. Follow standard procedures to update the infrastructure agent.

New Relic recommends that you upgrade the agent regularly and at a minimum every three months. As of this release, the oldest supported version is Infrastructure agent 1.27.3.

Changed

  • Update nri-prometheus to v2.18.4 #1681

June 16, 2023
Infrastructure agent v1.43.0

A new version of the agent has been released. Follow standard procedures to update the infrastructure agent.

New Relic recommends that you upgrade the agent regularly and at a minimum every three months. As of this release, the oldest supported version is Infrastructure agent 1.27.2.

Changed

  • Log negative CPU percent as a warning #1676
  • Bump fluent-bit-plugin version to 1.17.1 #1677

June 9, 2023
Infrastructure agent v1.42.5

A new version of the agent has been released. Follow standard procedures to update the infrastructure agent.

New Relic recommends that you upgrade the agent regularly and at a minimum every three months. As of this release, the oldest supported version is Infrastructure agent 1.27.1.

Changed

  • Bump github.com/containerd/containerd from v1.5.10 to v1.5.18 #1674

June 1, 2023
Infrastructure agent v1.42.4

A new version of the agent has been released. Follow standard procedures to update the infrastructure agent.

New Relic recommends that you upgrade the agent regularly and at a minimum every three months. As of this release, the oldest supported version is Infrastructure agent 1.27.0.

Changed

  • Bump newrelic/nri-docker to v1.8.6 #1673

Infrastructure agent v1.42.3

A new version of the agent has been released. Follow standard procedures to update the infrastructure agent.

We recommend that you update the agent regularly and at a minimum every three months. As of this release, the oldest supported version is infrastructure agent 1.27.0.

Fixed

  • Ensure containerDecorator is not nil in containerd environments

Infrastructure agent v1.42.2

A new version of the agent has been released. Follow standard procedures to update the Infrastructure agent.

We recommend that you upgrade the agent regularly and at a minimum every 3 months. As of this release, the oldest supported version is Infrastructure agent 1.27.0.

Added

  • Support Fluent Bit Use_ANSI flag in #1661.

Changed

  • Bump nri-flex version to 1.8.5 in #1668.
  • Bump nri-prometheus version to 2.18.1 in #1665.
  • Bump nri-docker version to 1.8.4 in #1660.

Fixed

  • msi checks performed before creating agent data directory in #1635.

May 24, 2023
Infrastructure agent v1.42.1

A new version of the infrastructure agent is available. Update the Infrastructure agent regularly, at least every three months.

As of this release, the oldest supported version is Infrastructure agent 1.26.0.

Changed

  • Bumped nri-docker version to v1.8.2 in #1663.
  • Bumped Go version to 1.19.9 and docker dependencies in #1664.

Fixed

  • Don't use ipv6-prefixed localhost hostnames as a fully qualified domain name. Fixed in #1662.

May 18, 2023
Infrastructure agent v1.42.0

A new version of the agent has been released. Follow standard procedures to update the Infrastructure agent.

We recommend that you upgrade the agent regularly and at a minimum every 3 months. As of this release, the oldest supported version is Infrastructure agent 1.25.0.

Added

  • Support for containerd as container runtime in process monitoring
  • Use enable_wmi_proc_data to enable process monitoring via WMI on Windows (when agent is run as non-admin or any restricted environment)
  • Using fluent-bit instead of td-agent package for log forwarding

Changed

  • Update dependency newrelic/nri-flex to v1.8.3
  • Update alpine docker tag to v3.18

Copyright © 2024 New Relic株式会社。

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.