• /
  • ログイン

Ruby agent v7.2.0

July 2, 2021Download

v7.2.0

  • Expected Errors and Ignore Errors This release adds support for configuration of expected/ignored errors by class name, status code, and message. The following configuration options are now available:

    • error_collector.ignore_classes
    • error_collector.ignore_messages
    • error_collector.ignore_status_codes
    • error_collector.expected_classes
    • error_collector.expected_messages
    • error_collector.expected_status_codes For more details about expected and ignored errors, please see our configuration documentation
  • Bugfix: resolves "can't add a new key into hash during iteration" Errors

    Thanks to @wyhaines for this fix that prevents "can't add a new key into hash during iteration" errors from occuring when iterating over environment data.

  • Bugfix: kwarg support fixed for Rack middleware instrumentation

    Thanks to @walro for submitting this fix. This fixes the rack instrumentation when using kwargs.

  • Update known conflicts with use of Module#Prepend

    With our release of v7.0.0, we updated our instrumentation to use Module#Prepend by default, instead of method chaining. We have received reports of conflicts and added a check for these known conflicts. If a known conflict with prepend is detected while using the default value of 'auto' for gem instrumentation, the agent will instead install method chaining instrumentation in order to avoid this conflict. This check can be bypassed by setting the instrumentation method for the gem to 'prepend'.

Support statement

New Relic recommends that you upgrade the agent regularly and at a minimum every 3 months. As of this release, the oldest supported version is 5.2.0.345.

問題を作成するこのページを編集する
Copyright © 2020 New Relic Inc.