• /
  • ログイン
  • 無料アカウント

Python agent v4.0.0.99

July 23, 2018Download

Notes

This release of the Python agent removes previously deprecated APIs, and removes support for Python 2.6 and Python 3.3.

The agent can be installed using easy_install/pip/distribute via the Python Package Index or can be downloaded directly from the New Relic download site.

Deprecations

  • Removed previously deprecated APIs

    The following APIs have been removed:

    • Transaction.add_user_attribute (use Transaction.add_custom_parameter)
    • Transaction.add_user_attributes (use Transaction.add_custom_parameters)
    • wrap_callable (use FunctionWrapper)
  • Removed support for Python 2.6 and Python 3.3

    Python 2.6 and Python 3.3 are no longer supported. Please consider upgrading your application to a supported version of Python in order to continue to receive updates to the Python Agent.

問題を作成するこのページを編集する
Copyright © 2020 New Relic Inc.