• /
  • ログイン

PHP agent v9.17.0.300

April 21, 2021Download

End of life notices

  • This will be the last release in which ZTS builds are supported. In the future, ZTS builds may not be provided, and support may be completely pulled from the codebase.
  • New Relic no longer supports PHP 5.3 or PHP 5.4. New Relic highly encourages upgrading to a supported version of PHP. If you would like to continue running the New Relic PHP agent with PHP 5.3 or 5.4, we recommend using version 9.16 of the agent. However, please note that we can only offer limited support in this case.
  • Ubuntu LTS versions earlier than 14.04, Ubuntu non-LTS versions earlier than 19.04, and Debian versions earlier than 7 "wheezy" are no longer supported.
  • The following frameworks or framework versions are no longer supported and may be removed from future agent builds:
    • Cake PHP 1.x
    • Joomla 1.5, 1.6, and 2.x
    • Kohana
    • Silex 1.x and 2.x
    • Symfony 1.x and 2.x

New features

  • The agent now supports 64-bit PHP 8.0! Compatibility note: When PHP 8.0 detects the New Relic agent, it disables JIT.
  • mysqli_commit is now instrumented.

Bug fixes

  • Fixed a memory leak that occurred when short lived segments throw exceptions.
  • Fixed a build up of duplicate distributed tracing headers that sometimes occurred when using file_get_contents.
  • Fixed an issue where Laravel Lumen transactions were not being properly named.

Support statement

  • New Relic recommends that you upgrade the agent regularly and at a minimum every 3 months. As of this release, the oldest supported version is 8.6.0.
問題を作成するこのページを編集する
Copyright © 2020 New Relic Inc.