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Dépannage du New Relic MCP

Le flux OAuth ne démarre pas

  • Assurez-vous que votre navigateur peut accéder à localhost.
  • Vérifiez les paramètres du pare-feu.
  • Vérifiez que vos outils peuvent accéder aux URL OAuth.

La clé API ne fonctionne pas

  • Vérifiez le format de la clé (commence par NRAK-).
  • Vérifiez les autorisations clés dans New Relic.
  • Vérifiez que la clé n'a pas expiré.

Serveur MCP non détecté

  • Redémarrez complètement l'application.
  • Vérifier la validité de la syntaxe JSON.
  • Vérifiez les chemins d'accès aux fichiers et les autorisations.

Problèmes de proxy mcp-remote

  • Assurez-vous que Node.js est installé.
  • Vérifiez votre connexion internet.
  • Vérifiez que npx peut accéder au package mcp-remote.

Accès refusé pour les groupes personnalisés

Problème

Vous ne pouvez pas vous connecter ou vous authentifier auprès du serveur New Relic AI MCP et recevez le message d'erreur suivant : Missing required capabilities to access MCP server. Please ensure you have the necessary permissions. Cela se produit généralement si vous êtes membre d'un groupe d'utilisateurs personnalisé sans aucune autorisation au niveau de l'organisation.

Cause

Votre groupe ne dispose pas d'un rôle à l'échelle de l'organisation lui permettant de lire le serveur MCP. L'accès à cette fonctionnalité à l'échelle de l'organisation doit être explicitement accordé à votre groupe via un rôle à portée organisationnelle.

Résolution

L'administrateur de votre organisation qui possède le rôle Authentication Domain Manager doit mettre en œuvre l'une des deux solutions suivantes pour vous accorder l'accès :

  1. Attribuez à votre groupe un rôle avec l'autorisation de lire le serveur MCP :

  2. Vous ajouter à un groupe autorisé :

    • L'administrateur doit vous ajouter à un groupe d'utilisateurs existant qui possède déjà un rôle à l'échelle de l'organisation avec l'autorisation de lire le serveur MCP.

Pour des informations détaillées sur les concepts de gestion des utilisateurs, les rôles et les autorisations d'organisation, reportez-vous à la documentation de gestion des utilisateurs de New Relic. Si votre organisation utilise un système de gestion des identités interdomaines (SCIM) pour la gestion des utilisateurs, ces ajustements de groupe et de rôle doivent être effectués au sein de votre fournisseur d'identité externe (IdP).

Messages d’erreur

  • Connexion refusée: Vérifiez l'URL et la connectivité réseau de vos outils.
  • Authentification requise: Vérifiez que la clé API est toujours active et qu'elle a été saisie correctement ou terminez le flux OAuth.
  • Client invalide: problème de configuration OAuth, essayez le proxy mcp-remote.
  • Time.UnmarshalJSON: Utiliser mcp-remote comme proxy pour OAuth.
Droits d'auteur © 2026 New Relic Inc.

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