Android 5.7.0

Released on: 
Thursday, August 4, 2016 - 16:00

New in this release

  • We are pleased to announce support for Dexguard.
    • Full build time compatibility with Dexguard version 7.2.04 or higher
    • Full instrumentation support​
    • De-obfuscated crash report​ stack traces​

Fixes

  • The New Relic Gradle plugin depends on the Android application or library plugin having been installed first. The New Relic plugin now throws a Gradle runtime exception, which includes instructions on how to fix the problem, if it is applied before Android.
  • Interaction trace completion was blocked on the sampling tasks running during the interaction. Any running sample tasks are stopped immediately when the interaction trace completes.

Changes

  • The Android agent now requires Proguard version 5.0 or higher for Proguard support