• Log inStart now

Kubernetes integration v2.8.1

September 28, 2021

Breaking changes

  • With the addition of Kubernetes 1.22.x support, we are phasing out of the support bracket Kubernetes versions 1.15.x and below. This means the supported versions bracket for this version and the rest of the nri-kubernetes 2.8.x branch is from Kubernetes v1.16.x to v1.22.x.
  • Users may still use previous versions of the integration and their Helm charts to instrument their clusters, and limited support will be offered for them. Development for said older versions is considered stopped and New Relic does not guarantee feature parity or bugfixes (security or otherwise) for those older versions.

Changed

  • Node status and conditions are now fetched from the API Server rather than KSM, which fixes some inconsistencies in the samples. This does not change which data is reported, and should be an invisible change. (#194).
  • Add a series of parameters which allow to configure a jitter to be applied to API Server response caching, which might help to spread the load on large clusters. (#185).
Copyright © 2022 New Relic Inc.

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.