PHP Agent 7.3.0.193

Released on: 
Monday, June 26, 2017 - 10:20

Upgrade Notices

  • Laravel Queue instrumentation has been updated to better interoperate with other New Relic APM features. It is possible that messages sent from PHP installs running version 7.3 (or later) of the PHP agent may not be correctly linked to the message queue worker transaction if the worker is running with version 7.2 or earlier of the PHP agent.

    If you use the Laravel Queue instrumentation, we recommend ensuring that all agents used to produce and consume messages are upgraded to version 7.3 simultaneously to avoid unexpected service map issues.

Bug Fixes

  • Compatibility with extensions that install opcode handlers on PHP 7 has been improved, most notably with uopz. While we still do not recommend using other extensions that hook deeply into PHP (such as uopz, runkit, or xdebug) with the New Relic PHP agent, this change should result in improved functionality.

  • A potential segfault when using Predis in a session handler invoked at request shutdown has been fixed.

  • External requests issued using Guzzle 6 are now properly instrumented when the GuzzleHttp\Client class has been extended.