Node Agent 1.7.0

Released on: 
Thursday, May 29, 2014 - 15:37
End of Life

The end-of-life date for this agent version is July 29, 2019. To update to the latest agent version, see Update the agent. For more information, see End-of-life policy.

Notes

  • Client side setting of high_security is now supported.

    High Security Mode is a feature to prevent any sensitive data from being sent to New Relic. The local setting for the agent must match the server setting in the New Relic APM UI. If there is a mismatch, the agent will log a message and act as if it is disabled. A link to the docs for High Security Mode can be found here

    Attributes of high security mode (when enabled):

    • requires ssl
    • does not allow capturing of parameters,
    • does not allow custom parameters

    The default setting for High Security Mode is ‘false’.

    Note: If you currently have high security mode enabled within the New Relic APM UI, you have to add high_security: true to your local newrelic.js.

  • Fixed a bug in our instrumentation of restify, where if you were using the restify client with express as a web server, req.query would be overridden.