Node Agent 1.23.0

Released on: 
Thursday, October 29, 2015 - 12:00

Notes

  • The New Relic Node Agent now officially supports Node v4!

    We are excited to announce that the New Relic Node Agent officially supports Node v4.x! We've tested the agent across all major versions of Node used by New Relic customers to ensure a quality Node APM experience. New Relic recommends upgrading to Node v4.x for best Node Agent performance.

  • Corrected a parsing issue in the slow sql query parsing step.

    Previously, the agent would not be able to parse inputs to database libraries that specified sql as an option param. This was an issue with node-mysql, namely. The agent now correctly handles this case and registers the queries as expected.